x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot Teleport Custom Pawn

I am trying to teleport my pawn and it's not working. The Blueprint is in the pawn bp itself and the rest of the script runs fine, but it will not teleport. I have tried Teleport, SetActorLocation, and SetActorLocationAndRotation. I have also tried setting the target to self.alt text

Product Version: UE 4.19
Tags:
grrrrrr.png (437.7 kB)
more ▼

asked Jul 30 '18 at 09:27 PM in Blueprint Scripting

avatar image

AlienRadar
5 3 2 4

avatar image Nebula Games Inc Jul 30 '18 at 11:07 PM
  1. Is the "golfball" actually the player pawn that is being controlled in your game?

  2. You know your current teleport location is set to 0,0,0?

  3. I don't understand your "switch on int" the one off the "true" branch goes to nothing, the one off the false doesn't need to "switch" at all since there is only 1 input. And if that input isn't "1" it won't execute.

So there are many things that could be wrong with this blueprint.

Here is a tutorial I made going over "teleportation" maybe it can help you figure out what your issue is.

https://youtu.be/c5smu-Mjusc

avatar image AlienRadar Jul 30 '18 at 11:12 PM

1) Yes, the golf ball is being played.

2) Yes, it doesnt teleport no matter the coordinates.

3) The switch on the top I haven't done yet as it also requires teleportation and the switch on the bottom will lead to more, I just haven't done it yet for the same reason as the top. All the code works fine, I have tested each section with a print screen after each node, it just doesn't teleport.

avatar image Nebula Games Inc Jul 30 '18 at 11:31 PM

Hmm, maybe a setting like "simulate physics" or something, sometimes physics doesn't like to play nice with other nodes.

avatar image AlienRadar Jul 31 '18 at 12:14 AM

Actually, it didn't work. I have no idea why it worked that one time, but it doesn't now.

avatar image Nebula Games Inc Jul 31 '18 at 03:16 AM

Are you sure each component has physics turned off? Also maybe try "set actor location" instead of the "teleport" unless you specifically need to use that node.

avatar image AlienRadar Jul 31 '18 at 03:31 AM

Only the sphere has collision, which is now turned off. I have tried both Teleport and SetActorLocation, neither of them work.

avatar image Nebula Games Inc Jul 31 '18 at 03:39 AM

Hmm, but you say it did work for one trial? Weird, can you post the full blueprint for this? How the entire thing is called and executed start to finish?

avatar image AlienRadar Jul 31 '18 at 03:45 AM

I think that one trial is because I accidentally crushed the ball through the floor. The whole process spans multiple blueprints and is very unoptimized. The node does get called, however it doesn't teleport. Hopefully you'll be able to see those. link text

hi.zip (233.4 kB)
avatar image Nebula Games Inc Aug 01 '18 at 02:06 AM

Sorry, I don't have 4.19 could you possibly upload more screen shots for me to look at?

avatar image AlienRadar Aug 01 '18 at 02:25 AM

Its fine. Im not gonna finish this as there are a million more problems with it.

avatar image Nebula Games Inc Aug 01 '18 at 02:29 AM

Teleporting doesn't seem like it should be that big of an issue, it is probably something small/simple you are missing but if you don't want to try and fix it I guess I can't stop you haha

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question