Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Occlusion culling laggy?

Hey I'm currently working on a fast paced drone game and I seem to have found a weakness in the built in occlusion culling, I don't want to disable it as it will be needed for performance in the future but was curious if there was a way to increase tolerances or eliminate this frame or two of lag?

Example video: https://www.youtube.com/watch?v=hTzI-2EyRe0

Product Version: UE 4.19
more ▼

asked Jul 31 '18 at 02:09 PM in Rendering

avatar image

1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

That is expected side effect. Consider increasing overall framerate of your game, changing lighting setup, so that popping is not that visible, or disabling occlusion culling in project settings.

more ▼

answered Jul 31 '18 at 03:00 PM

avatar image

7.8k 130 31 292

avatar image MissKraya Jul 31 '18 at 04:45 PM

It definitely isn't intended... the game is running at 120fps in the video and I should be able to have dark indoor areas and not have to worry about this...If UE4 automatically culls objects there must be a tolerance setting somewhere.

avatar image Deathrey Aug 02 '18 at 07:57 AM

Yeah, this is totally intended due to how occlusion culling works. You can increase bounds scale of the objects, that give you problems, but it won't hold up on fast camera turns and will reduce effectiveness of culling to the point, where you might be better of extinguishing it completely.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This is due to the GPU occlusion culling. there is a one frame lag. If you want to avoid it, Epic implemented software occlusion culling in 4.20. Switch to this should avoid the one frame delay but will increase the cpu workload. Its probably best to use it if you dont have too many objects. Try to use precomputed visibility culling, to save some performance there.

more ▼

answered Aug 02 '18 at 10:51 AM

avatar image

153 6 11 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question