x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Things stop working

Hello! My Inventory script was perfect. It had worked. I saved it. Opened the project on the other day and it didn't work :( It had happened before but I just restarted the engine and it was fixed but this time this don't do anything. Please help!!!

Product Version: UE 4.20
Tags:
more ▼

asked Jul 31 '18 at 02:59 PM in Using UE4

avatar image

Whimfoome
1 1 2 1

avatar image Everynone Jul 31 '18 at 03:03 PM

There's nothing anyone can do with this amount of information. You need to do some step by step debugging. Use breakpoints, Print String nodes and the debug filter to observe data flows.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Oh thanks, I researched every function and an array get(copy) is keeping to unplug automatic when I change something in the slot structure(it affects "slot contents").alt text Do you know why is it happening?

more ▼

answered Jul 31 '18 at 03:23 PM

avatar image

Whimfoome
1 1 2 1

avatar image Everynone Jul 31 '18 at 03:30 PM

I think I know what you mean.

The signature of the struct changes (because you've applied changes to the struct) and the currently plugged one becomes invalid. This is quite common with structs. Unfortunately there's little you can do about this.

This becomes quite problematic if you have 100 of these unplugging because of the changes to the struct. One way to work around it, is to:

  • save all

  • make changes to the struct

  • save just struct

  • quit the editor but skip saving any blueprints that referenced the struct

  • it should work fine after restarting


Also, you right click the struct to Find References and then click the binoculars icon on the very right (bottom) to see where this struct was used and manually recompile the blueprints showing errors.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question