x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Masked Material issue

Hello.

I noticed a strange behavior of my masked Materials I can't understand. When I have a gradient alpha on my texture, and plug it in the Opacity Mask Output, it renders as a 'step translucent-like' material. There are parts of my material which are semi-opaque, which is not supposed to be possible.

I tried creating new materials, restarting ue4, but it is persistent.

The project is currently in Forward Rendering and source controlled by SVN, but other members in the team do not have the issue on the same project.

Is there a project setting that could interfere with alpha-test, or anything that could explain that?

Thanks in advance !

the gradient: alt text the result: alt text

Product Version: UE 4.19
Tags:
alphatest-01.png (524.6 kB)
alphatest-02.png (547.9 kB)
more ▼

asked Aug 02 '18 at 09:30 AM in Using UE4

avatar image

apprenti90
23 1 3

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Most likely caused by MSAA / alpha to coverage.

more ▼

answered Aug 02 '18 at 12:21 PM

avatar image

Deathrey
7.7k 129 29 290

avatar image apprenti90 Aug 02 '18 at 01:05 PM

MSAA Indeed. Thanks a lot. Knowing that, I also found another thread for more info: https://answers.unrealengine.com/questions/556469/415-p2-msaa-and-alpha2coverage-problem.html

(comments are locked)
10|2000 characters needed characters left

Your Opacity clip mask value is 0.1

try setting it to 0 or 1

more ▼

answered Aug 02 '18 at 09:48 AM

avatar image

HarryHighDef
1.3k 1 14 16

avatar image Luos Aug 02 '18 at 09:54 AM

actually, generally its set to 0.33.

avatar image apprenti90 Aug 02 '18 at 11:54 AM

it should not be the cause and it does not seem to be, but thanks for the suggestion alt text

alphatest-03.png (542.3 kB)
(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question