x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Upgrade to 4.20 causes the editor to freeze when loading streaming levels

After upgrading the game from 4.19.2 to 4.20.1 when pressing play in the editor or creating a standalone build, the game freezes when it needs to load streaming levels. While in the editor, the entire engine becomes non-responsive.

When these streaming levels are loaded individually, the game works as intended without any freezes.

Is there a way to debug this? as there is no crash report or any crash in general. The game just stays in limbo. Thanks a lot!

Product Version: UE 4.20
Tags:
more ▼

asked Aug 02 '18 at 03:09 PM in Bug Reports

avatar image

namanmerchant
6 1 1

avatar image Jeff A ♦♦ STAFF Aug 02 '18 at 08:15 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

avatar image Ruffhaus Games Aug 31 '18 at 09:43 AM

Having the same issue in 4.20.2, but only with levels that are set to the "Blueprint" streaming method. Any levels set to "Always Loaded" work as intended but if any levels that are set to "Blueprint" the game won't start at all, and locking up the editor or a built/launched version of the game, making it very hard to debug.

I've also been seeing red crosses on the save icon in the Levels window, which I've never seen before and am not sure what they are representing, or if they're relevant to the issue at all, I've come up with nothing from documentation and have scoured the 4.20 release notes but been unable to find any mention of changes to level streaming.

I've been unable to reproduce this issue in a new project, even creating it in 4.19 and updating that project, so it seems to be project related but cannot for the life of me work it out.

If any other people are having the same issue or have found a workaround/fix, I'd love to hear how you solved it.

avatar image Ruffhaus Games Sep 03 '18 at 04:53 AM

I was able to get it to work as it was, by setting "Use Background Level Streaming" to true in the Project Settings. It would still be good to get some clarification on what changed between engine versions, just so I could understand the problem better and maybe improve my workflow if anyone has any idea.

avatar image bkz444 Sep 27 '18 at 10:17 PM

Im having the same problem using the load level instance blueprint node in 4.20.3 It worked fine in previous versions and now locks the game. "use background level streaming" is already set to true for me and did not help.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question