x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Modding using DLC / Plugins system

I have tried every solution I know of for days now, hope someone can help me out!

My goal: I am creating a base game. Separate .pak files that the game shouldn't know anything about can be added and loaded on demand (metadata would be included in a separate file). In my case, a pak mod needs to be capable of loading a map which may contain custom assets. Inheriting from the base game's classes (blueprint) needs to be possible as well.

EDIT: Related question here.

The problem: The content inside can not be loaded. More info below.


What I tried: The DLC system of the Project Launcher seems perfect for this, but it has only caused trouble so far. UE4 loads the pak file automatically (shown in the log) if put into the Content/Paks folder, but opening the map contained does not work. (Should this work as it is?)

Mounting the pak file using this method allowed the map to load, but its content failed to load: DoesPackageExist FAILED: '/PAKNAME/Assets/example' is not a standard unreal filename or a long path name. Reason: Path does not start with a valid root.

Mounting the pak file using another method did not work at all, the map file was not found when attempted to open.

In all cases, I verified that the pak contained everything using UnrealPak.
I also made sure that all mod plugins were disabled when building the base game.

All was tested in staged development and shipping builds.

EDIT: Using FPackageName::RegisterMountPoint with the dlc's name results in only the custom content showing, while engine/base game content fails to load with the generic error message ERROR: Couldn't find file for package.


I would greatly appreciate any help. May it be a way to fix the problems I've run into, or another method to achieve what I'm trying to accomplish.

Product Version: UE 4.20
Tags:
more ▼

asked Aug 05 '18 at 04:53 PM in Packaging & Deployment

avatar image

RedMser
21 1 5

avatar image Bariudol Aug 30 '18 at 12:18 PM

Did you ever find a solution for this? I'm working on a project with similar demands, we were using an old plugin to achieve this until version 4.14. We are trying to update to 4.20 but we are having the exact same problem you are.

In a related post (https://answers.unrealengine.com/questions/194148/mounting-pak-files-at-runtime-1.html) they mention that setting EXCLUDE_NONPAK_UE_EXTENSIONS = 0 in IPakPlatformFile.cpp solves the issue and allows for loading lose files, however it requieres recompiling the engine, which is not an option for us right now.

avatar image RedMser Aug 30 '18 at 12:28 PM

EXCLUDE_NONPAK_UE_EXTENSIONS = 0 only seems to change anything when loading uasset files directly. Additionally, in the source code, it shows that the value only makes a difference when doing a shipping build, but even development builds did not work out for me. :(

The only solution I found so far, although not ideal, is to add placeholder plugins to the project in advance, but not ship any pak files for them until later. The plugin names are stored in the exe, but obviously won't be loaded until you include any content and ship the pak file. Of course, this won't work with a user-based modding system, but if you are planning on adding DLC to your game, it seems viable enough.

avatar image Gwenn Nov 12 '18 at 12:26 PM

Same issue on our side. We'd love to load mods from an arbitrary PAK file at runtime, and we've yet to find any method that allows it.

avatar image Editaw5X Jan 05 '19 at 09:37 AM

Same issue.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question