x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Braking deceleration in flying character movement

I am looking to make a game in a zero gravity setting, and I've set up a character that starts default in the flying character movement mode. Whenever I add input, I want the physics engine to simulate absolutely zero drag or any other frictional braking. Unfortunately, even when setting the Braking Deceleration Flying multiplier to 0.0, there is still a very minuscule amount of braking going on. I can not find any other braking setting in the character movement.

Is there a way to completely disable braking in blueprints? I'd love to set it up manually.

Product Version: UE 4.20
Tags:
more ▼

asked Aug 05 '18 at 06:34 PM in Blueprint Scripting

avatar image

Sensing
1

avatar image Tuerer Aug 05 '18 at 07:49 PM

What about linear damping? By default it's 0.01 I believe.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Was struggling with the same problem on a spaceship prototype. Everything was zero or disabled.

alt text

Fluid Friction to zero turned it off completely for the spaceship. Far as I understand it's simulating air friction using the value from DefaultPhysicsVolume in World Settings. Couldn't find it anywhere as a setting but that does the trick.

Might be related to the Fluid Friction value in Project Settings under Engine - Physics but changing the default friction there had no effect.

fluidfriction.png (56.4 kB)
more ▼

answered Aug 10 '18 at 08:48 PM

avatar image

Icey Guy
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question