x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Get Acceleration node not working with custom character movement

![alt text][1]

Hey all! I am trying to make a system where your acceleration is lowered when you first start running, and after you get a certain velocity, acceleration is increased (Not sure if it works in this state) The problem is, i'm using a custom character component, which does not work with the acceleration node even though It's almost identical to the basic 3d pawn otherwise. [1]: /storage/temp/249784-oh.png

Product Version: Epic Games Launcher
Tags:
oh.png (309.6 kB)
more ▼

asked Aug 08 '18 at 05:28 AM in Blueprint Scripting

avatar image

The Bonk Batter
27 1 1 6

avatar image The Bonk Batter Aug 09 '18 at 08:38 PM

Or is it impossible?

avatar image The Bonk Batter Aug 10 '18 at 07:16 AM

To have a slow start up, or custom gravity... Well, This is what i get for using blueprints.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You probably need to get a reference to your movement component and pin it in there.

more ▼

answered Aug 10 '18 at 08:26 AM

avatar image

HarryHighDef
724 1 11 15

avatar image The Bonk Batter Aug 10 '18 at 08:48 PM

Yeah, probably. How would i do so? Using a cast node?

Okay, so cast does not work. It's still not compatible. Would i have to make my own get acceleration node for it?

bump because i am impatient, but thanks for helping :)

![alt text][1]

Yeah, This is annoying. [1]: /storage/temp/250431-oh-my-god-help.png

oh-my-god-help.png (189.7 kB)
avatar image HarryHighDef 4 days ago

What is the type of your movement component?

It's a "Custom Movement Component", Inherited from C++, Introduced in custom pawn and non-scene component. Does that help?

avatar image HarryHighDef 3 days ago

You should be able to drag off the cast node and type "Set Max Acceleration" is should connect.

alt text Apparently not, for some reason.

nut.png (218.6 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question