x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Launch on Android: Module 'LiveLink' not found

Hi everybody!

I just migrated an existing Daydream/GearVR App to UE 4.20.1, which launched fine in UE 4.19.3, but now errors out on launch on the device (from the editor) with

LogModuleManager: Warning: ModuleManager: Module 'LiveLink' not found - its StaticallyLinkedModuleInitializers function is null.

and also get a popup on the device saying so.

I then tried explicitly disabling the LiveLink plugin in the .uproject file which did not help.

Any help is greatly appreciated. Cheers, Jonathan.

Product Version: UE 4.20
Tags:
more ▼

asked Aug 10 '18 at 11:24 AM in Packaging & Deployment

avatar image

Squareys
111 2 7 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Alright, I enabled the LiveLink plugin now and it works!

My guess is that some module now links to this plugin without specifying the plugin dependency. As I cannot imagine that LiveLink should be required at Runtime, probably the Link should remove.

~~~I will report an issue in the bug tracker.~~~ (Turns out I am unable to do so, or don't know how to, so let's hope some Unreal Engine staff stumbles over this question)

more ▼

answered Aug 10 '18 at 11:36 AM

avatar image

Squareys
111 2 7 8

avatar image Ben_Cykyria Sep 21 '18 at 01:32 PM

I still have this in 4.20.3 too. Did you get any feedback to your bug report? Enabling the Livelink plugin worked, though.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question