x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

NavMesh Bounds Volume not working

I´ve tried many tutorials and forum posts to findo the solution for my problem, but i anything worked for me. When i create the NavMesh Bounds Volume, it doesn´t shows the green tile or event the red one, nothing.

The weird thing that when i tested in a blank project, it works, i´ve tried to delete and created a new one, but didn´t work.

I just created a simples AI Controller with IDLE and MOVE TO, as you can see in the pics below.

alt text

alt text

alt text

I don´t know why, i´ve checked if there is a redundant (more than one of the same) volume, there isn´t.

Please help, even if i create a simple node as "Move to" instead of creating from Blackboard, also doesn´t work at all.

Product Version: UE 4.19
Tags:
ai.png (302.7 kB)
aicontroller.png (413.0 kB)
navmesh.png (1.4 MB)
more ▼

asked Aug 12 '18 at 08:08 PM in Blueprint Scripting

avatar image

BrunoChaves
136 10 8 14

avatar image Nebula Games Inc Aug 12 '18 at 10:11 PM

Does your nav mesh actually touch the ground? Says the "Z" location is like ~300. Try increasing the "Z" scale for the mesh or moving it down and see if it will populate the green grid when you hit the "P" key.

avatar image BrunoChaves Aug 13 '18 at 02:35 AM

Yes. It touches the ground. For some reason, it works in another level i´ve created before. I checked the similarity, and has the same configuration, but i can´t say what provokes this issue, i assume that the problem has something to do with the Nav Mesh Bounds and physics, perhaps?

The AI is working in other levels, but not in this one i showed.

avatar image ttolujob Oct 16 '18 at 11:55 PM

Did you ever find an answer? I'm having similar issues.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question