x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why does my Point Light emit in only one direction like a Spot light?

No idea how to describe this, so here's a screenshot: alt text

I have this really strange lighting behavior where point lights emit in one direction (which varies on different objects), spotlights do nothing at all, and some objects have a mix of lit and unlit faces.

I just nuked my whole UE environment, downloaded the dependencies, rebuilt from source, and created a new level. No idea what's going on. Any suggestions?

Product Version: Not Selected
Tags:
lighting issue.jpg (163.8 kB)
more ▼

asked Aug 11 '14 at 03:44 AM in Rendering

avatar image

wheel
11 2 5 5

avatar image Lovecraft_K ♦♦ STAFF Aug 11 '14 at 01:41 PM

Hey wheel -

Thank you for your report. I will begin investigation into this issue as soon as possible. Can you let me know what version of the engine you are using and feel free to edit your post if you have additional information to provide, a good template can be found here:

https://answers.unrealengine.com/questions/12363/how-do-i-report-a-bug.html

Also please let me know what types of lights you are using in your scene, are they Static, Stationary or Movable?

Thank you.

Eric Ketchum

avatar image wheel Aug 11 '14 at 06:15 PM

Currently on lunch, but I have a bit more information from last night:

  • Shared the test levels I made with my collaborator, they're hosed on his end as well.

  • We're using a very slightly customized branch of 4.3, I don't think there are any real modifications yet, we just set it up that way in preparation for any engine changes we do later. I'll verify and see what else we've touched.

  • The problem is specific to this uproject. I tried other existing projects plus a brand new project, and everything works as expected in those.

  • The existing sample level that came from the template still works as expected, it's only appearing in new levels that I add. Possibly related to that level being created in a previous version of the editor?

  • I believe the lights are stationary, but will verify that tonight also.

My initial guess from objects like the sphere was that it's something going wrong in mapping the lightmap images back onto objects for rendering, but the directional light coming from default point lights makes me think there's more to it.

Given that it's only happening in one project, any suggestions for how to narrow it down? I'm planning to have him create a new level and send it to me in case that has a different result, but I could use other suggestions.

System information: Windows 8.1 Update 1 with a Radeon HD 6870. I'll check driver version tonight and make sure that's all up to date.

avatar image wheel Aug 11 '14 at 10:53 PM

More updates! Turns out he has the same issues that I do in levels other than Example_Map for this project. Copies of Example_Map work, but new ones based off of Default or Empty level are borked.

Here's a screenshot based on Empty Level, with just a few BSP objects and a point light:

alt text

Same result regardless of static/stationary/movable type. Rotating the point light has no effect on the lighting (it always points -x on the ground).

For engine version, we're on 4.3 with a few config file changes. There are a couple of patches that we could rebuild with, but it looks like they're all unrelated bugfixes.

I'm fairly sure this was working in 4.2, but it's possible it showed up when 4.3 came out and we just now noticed when we tried to add levels.

Both of us have HD 6870s, I'm on AMD driver packaging version 14.10-140415a-170730E. He probably has a slightly newer version.

avatar image Lovecraft_K ♦♦ STAFF Aug 12 '14 at 01:51 PM

Hey wheel -

So I've been trying to duplicate this in 4.30, 4.3.1 and 4.4.0 Preview, so far, I haven't been successful. Can you try to duplicate this issue in a version of the engine that has no config or coding changes whatsoever?

Thank You

Eric Ketchum

avatar image wheel Aug 14 '14 at 12:14 AM

Should be able to check the engine in a bit (downloading and compiling shaders takes a while), but in the meantime I've narrowed it down to a project problem.

If I make a level in this project and then copy it to another it works fine there.

Similarly, if I make a level in another project and copy it to this one, lighting is screwed up.

Any suggestions on what might cause this with one project?

avatar image wheel Aug 14 '14 at 12:21 AM

Here's the lighting in a prebuilt engine, looks the same as our builds:

alt text

prebuilt engine.jpg (174.0 kB)
avatar image Lovecraft_K ♦♦ STAFF Aug 14 '14 at 01:36 PM

Hey wheel -

Can you let me know (screenshot if possible) what the settings for the light in the above image and what your Edit >> Project Settings >> Rendering are?

Thank You

Eric Ketchum

avatar image wheel Aug 17 '14 at 08:25 PM

Not that specific light (didn't keep that map), but a screenshot of a light exhibiting the same problem:

alt text

No IES Texture, everything on the defaults from I dragged it out of the Place tab.

avatar image wheel Aug 17 '14 at 08:26 PM

And another addendum, I have spotlights doing the same thing:

alt text

spotlights.jpg (108.2 kB)
avatar image Lovecraft_K ♦♦ STAFF Aug 18 '14 at 01:48 PM

Hey wheel -

Go into a project that has this issue in your Windows Explorer and delete the saved and intermediate sub-directories. This should force you to recompile all shaders when you next open the editor and have to rebuild lighting.

Let me know if this helps or if it rebuilds to the same error -

Eric Ketchum

avatar image Roel Aug 24 '14 at 11:57 AM

I had this issue using brushes. When rebuilding everything with static meshes the problem was gone. Brushes just don't work that well with dynamic lights. For high quality lighting, don't use brushes.

avatar image Lovecraft_K ♦♦ STAFF Aug 26 '14 at 07:42 PM

Hey wheel -

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Eric Ketchum

avatar image wheel Sep 06 '14 at 08:13 PM

Sorry about the delay on following up here, we never narrowed it down to the exact cause, but did figure out that it was a problem with our DefaultEngine.ini config.

And as a side-note for anyone reading back through this, the post title was changed, but as far as I can tell it's both the directional light problem and a separate one with lightmaps not getting mapped onto geometry correctly (see the spheres with random mixes of lit and unlit faces).

avatar image wheel Sep 06 '14 at 08:23 PM

Here's a copy of the broken ini that I pulled out of our git history. Wiping pretty much everything from [/Script/Engine.Engine] down got it back to working.

Unfortunately neither of us has any recollection of changing whatever caused this, since we didn't see the problem until a month or two later when we made a second level. I'm guessing that our testing level overrode whatever setting was breaking lightmass. Regardless, it's a simple fix once you know it's a config problem.

Attachment renamed to .txt because ini files aren't allowed. Might be a format worth whitelisting?

DefaultEngine.ini

defaultengine.txt (79.6 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey wheel -

I spent some time with your ini and have found the exact line which is causing the issue for you. It is under [/Script/Engine.RendererSettings]. Remove the line "Compat.UseDXT5NormalMaps=True" and the lights and Geometry Brushes will return to expected behavior.

Thank You

Eric Ketchum

more ▼

answered Sep 08 '14 at 01:49 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 736

avatar image JPKerwan Sep 18 '14 at 05:33 PM

Hey Eric, wondering if you had another solution. I've come across this same problem, but haven't altered anything in script. This issue only came up after attempting to use an IES texture, but now every light I drag in 'new', is clipped in the same fashion. Is there a way to reset the lighting without diving into the script?

avatar image Lovecraft_K ♦♦ STAFF Sep 18 '14 at 07:27 PM

Hey JPKerwan -

If you can send me a sample project showing this issue I will be happy to take a look at it.

Thank You

Eric Ketchum

avatar image wheel Sep 18 '14 at 09:17 PM

For what it's worth, neither of us manually changed Compat.UseDXT5NormalMaps or anything that seemed related, so our best theory was that it happened during a project version upgrade. You might try opening up your DefautEngine.ini file and checking just in case.

avatar image adriamorales103 Jul 28 '18 at 10:25 AM

Apparently, I have the same problem as wheel, but my case is that I can't find my DefaultEngine.ini file, weird. I tried putting wheel's DefaultEngine in it but everytime I try oppening my game it just doesnt open, it keeps running in the background and causing a lot of cpu usage. Still dont know how to resolve this problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question