x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

VR preview fails to enable HMD every second run

Hi,

I am not sure whether this is an intended behavior and I am just "holding it wrong", but I am having problems getting the HMD to be reliably enabled every time when I run the VR preview. I am using Oculus Rift and I can reproduce the problem by simply:

1) Create new project; select Virtual Reality template (blueprint); click Create Project,

2) optionally, open MotionControllerMap (not required, but illustrates the problem better),

3) run VR Preview,

4) close the preview using Alt+F4,

5) run VR Preview again (and repeat from step 4 if needed).

For me, this results in working VR preview in step 3 and stationary camera on the ground in step 5. If I run the preview repeatedly, it alternates between working and not working state.

When in the not working state, IsHeadMounterDisplayEnabled returns false, so I tried to add a call to EnableHMD from event BeginPlay, but it did not help. When I "brute force" the issue by calling EnableHMD repeatedly from event Tick, I can get the HMD enabled and working every time, but this is obviously an ugly hack and not a proper solution. :)

When I run it as Standalone Game, the HMD also does not work, but I assume that is a different issue, since "forcing" EnableHMD does not help in this case.

Product Version: UE 4.20
Tags:
more ▼

asked Aug 13 '18 at 01:47 PM in Bug Reports

avatar image

H-S_
1 1

avatar image Jeff A ♦♦ STAFF Aug 16 '18 at 07:13 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question