Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG Drag Drop Not Working - 4.20 (Packaged / Standalone)

We've encountered which seems to be a bug after upgrading our project to UE 4.20.1. Drag and drop operations just become broken on packaged builds or launching stand-alone, despite working inside the Editor (PIE).

I've created a new project to isolate the problem, this is how it is configured:

Slot component (which will be dragged): alt text alt text UMG UI (no behavior, just using the slot-component ui showed previously): alt text Level Blueprint (used to add the widget to screen) alt text

The problem: Each slot ca only be dragged once, after this "OnDragDetect" event will not trigger anymore, (this only occur when running Packaged builds or launching stand-alone version through the editor).

Is this an confirmed bug ? Any help would be appreciated. Thanks!

Product Version: UE 4.20
more ▼

asked Aug 14 '18 at 10:36 PM in Bug Reports

avatar image

13 1 4 7

avatar image Jeff A ♦♦ STAFF Aug 16 '18 at 07:11 PM


We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.



avatar image Animaxe Sep 18 '18 at 08:42 AM

I've reported the issue: UE-63076 (it can be found here), but it has been marked as "Non-Issue", what does that mean ? Does repro steps where unsuccessful ? Thanks.

avatar image Alexander S. Sep 18 '18 at 05:03 PM

Be wait together.

avatar image Animaxe Oct 01 '18 at 01:30 AM

I've created a repro project with this issue isolated. Playing "Stand Alone Game" behavior differs from editor and becomes broken after the first drag and drop. You can download it here.

avatar image Alexander S. Sep 05 '18 at 01:13 PM

Exactly same problem. Have any decision?

avatar image manuaganu Oct 17 '18 at 12:09 PM

same problem here

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

This problem was occurring since i was passing the same widget (self) as payload parameter during drag operation creation, which seems to trigger some recursive conflict on UMG input handling system. Passing only the image (or any other component) as payload parameter will fix this issue.

I still think this is a bug, since PIE / Stand Alone and Packaged version behaves differently, also, this was not happening on UE 4.19.

more ▼

answered Oct 03 '18 at 10:22 PM

avatar image

13 1 4 7

avatar image Flash7 Nov 30 '18 at 10:39 PM

4.21 It is still somewhat a problem. In packaged build, if you click and drag mouse quick, it will not perform a drag operation. It works if you do it slow (who does it slow?). But in PIE it works 100% regardless how fast I tried to click and drag.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Edit: It's not the payload that is the issue, its the Default Drag Visual, you will have to create a throw away widget in place of using self.

My default drag visual is the same as the widget being dragged, (No way! Like, who in their right mind does this right??!) which caused me this issue, after reading this post, removed the payload, and still had the same issue in standalone. After restoring payload to self, and removing the Default Drag Visual, all works again.

more ▼

answered May 03 '19 at 02:02 AM

avatar image

30 2 4 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Had the same issue with 4.22. I fixed it by using the Image variable instead of self. Also had to resize the image in my case. An additional widget was not necessary.

alt text

Still think the editor PIE should not behave different than the stand alone version in this case.

more ▼

answered Jun 09 '19 at 11:07 AM

avatar image

1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question