x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

link against static ignition library and static protobuf

Hello, I am working on integrating ignition-robotics library into Unreal to use its transport system.

I built protobuf as static library and linked static ignition against it and that worked and now I have my "*.a" files.

Now, I included those libraries in my project as ThirdParty static libs and tried to load the Unreal editor solution, there it throws me the following error :

[2018.08.15-16.42.46:949][ 0]LogLinux: Warning: dlopen failed: /home/user/Documents/Unreal Projects/IgnIntegrationPoc_4.19/Binaries/Linux/libUE4Editor-IgnIntegrationPoc.so: undefined symbol: _ZN6google8protobuf8internal26fixed_address_empty_stringE

tracing back that error, i found the following :

$ nm -D Binaries/Linux/libUE4Editor-IgnIntegrationPoc.so | grep _ZN6google8protobuf8internal26fixed_address_empty_stringE

U _ZN6google8protobuf8internal26fixed_address_empty_stringE

I tried the same with all the static libraries that I included, I never found this symbol in any of them. Tried different versions of protobuf (3.6.1) and (3.0.2) with different options "-fPIC -DGOOGLE_PROTOBUF_NO_RTTI -frandom-seed=string" and nothing changed. Still the same loading problem ...

Does anyone have an idea where this undefined symbol is coming from ?

Good to know, _ZN6google8protobuf8internal26fixed_address_empty_stringE the only undefined symbol that I found on my shared library "libUE4Editor-IgnIntegrationPoc.so". Curious ! ...

Cheers.

Product Version: UE 4.19
Tags:
more ▼

asked Aug 15 '18 at 05:09 PM in C++ Programming

avatar image

Vtik407
1 1

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Did you add your library to the ProjectName.Build.cs file?

 PublicAdditionalLibraries.Add(<path to the library>);

more ▼

answered Aug 15 '18 at 05:14 PM

avatar image

ekicam2
36 1 4 7

avatar image Vtik407 Aug 15 '18 at 05:31 PM

Yep. And Indeed, all the others google protobuf symbols are defined in the .so but that one.

avatar image Vtik407 Aug 15 '18 at 08:37 PM

Thx Eki but that didn't work. It complans that the resulting lib is mal formed...

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question