x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Skeletal mesh not colliding inside an actor blueprint

Hi, I have a skeletal mesh with its animation asset and a proper physics asset. When I bring it to the game and check simulate physics, it is colliding while animation is playing. As expected.

Now I'd like to use blueprint with this. But if I create an actor and add my skeletal mesh inside and simulate physics (same process), my actor is NOT colliding. I also tried with a pawn, same result. I didn't add any code for the moment. Also I get this error "Invalid simulate option : body is set to simulate physics but collision enabled is incompatible".

What am I doing wrong ?

Product Version: UE 4.20
Tags:
more ▼

asked Aug 17 '18 at 07:44 AM in Blueprint Scripting

avatar image

mathinfo11
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

It is exactly as the error says, the body is set to simulate physics but collision enabled is incompatible.

Try changing the Collision Enabled setting on your actor/pawn (Collision->Collision Presets->Collision Enabled) to either Collision Enabled(Query and Physics) or Physics Only(No Query Collision). You can do this by either selecting a preset that has this set, or by selecting custom preset and manually setting this.

alt text

more ▼

answered Aug 17 '18 at 06:17 PM

avatar image

Dakota.Carmer STAFF
36 2 2 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question