x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

*RESOLVED*Footsteps sound plays twice using blendspace

EDIT: RESOLVED ISSUE! I'll leave my super simple solution for anyone who encounters the same problem. It was indeed that the 2d blendspace was fired off twice, in my anim graph then state machine. I simply switched my DefaultSlot as Base Pose from the blendspace to the idle animation, effectively killing off the second set of sounds. Hope this helps anyone with this. So far as I understand, just dont use the same blendspace twice within your anim graph and state machine if you use Anim Notify for sounds. Cheers! **

Hello everyone!

I have a bit of a problem with my footsteps sound cue in my project.

I am creating a sidescrolling shooter (using the sidescroller template) and I have added sound cues for footsteps using Anim Notifies. Problem is this, if I launch the game and walk around, the footsteps sound fine. But, as soon as I jump, the sound cues fire off as if the character was walking normally, while in the air. When my character lands, the foostep sounds now play twice.

As far as animations go: I am using a 2d blendspace for the idle/run animation. However, I am also using an aimoffset so my character can aim and rotate, up and down, at the mouse location. Do achieve this effect with animations, I am using layered blend per bone. Also, my character can do this aiming also while in the air, using another layered blend per bone node so that the bottom half of the character plays the jumping animations while the top half still uses the aimoffset.

Now, I have looked for a good 17 hours now on how to stop the sound cues from playing twice. In my blendspace, the Notify Trigger Mode (in the Animation Notifies parameter of the blendspace) is set to Highest Weigthed Animation, as per suggested for people who have seemed to encounter this double sound issue.

I have tried to change the values for tor the Trigger Weight Threshold of the animation notifies that play the footsteps cue (leaving them to the default value or bumping all the notifies to 0.5) and trying out changing the Montage Tick Type from Queued to Branching Point but the problem still persists.

I have tried to replicate the issue using the FPS template, creating a Blendspace for the idle/run animations and setting anim notifies to play sound cues for footsteps and the same parameters for the Notify Trigger Mode (in the blendspace) and left the Trigger Weight Threshold and Montage tick Type (in the running animation) with their default settings. In the FPS test, the problem is not replicated (the footsteps don't play twice or while the character is in the air or start off twice while resuming the run animation).

I suspect that the problem is caused by my anim graph having the 2d blendpace firing off at more than one instance. The problem is, in order for my character to be able to aim, shoot and reload while doing any movement (running, jumping, falling), I have to use a Layered blend per bone node combining my state machine and my aimoffset. (see screenshot) and then, the 2d blendspace is used again in the idle/run node inside my state machine.

I'm pretty sure that's where the problem lied but I have no idea how to fix this. My animations might all be setup wrong using that way but it's the best way I found to achieve the results I wanted.

Any help is appreciated!

alt text alt text

Product Version: UE 4.20
Tags:
anim-graph.jpg (232.2 kB)
idle-run-state.jpg (207.9 kB)
more ▼

asked Aug 18 '18 at 08:33 PM in Using UE4

avatar image

r0stro
10 2 5

avatar image Crazy Rabbits Jan 02 '19 at 12:55 PM

I also encountered this problem, I don't know how to solve it.

avatar image r0stro Jan 03 '19 at 12:14 AM

Check the top of the top of the post, the solution to my problem is put in bold!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Check the top of the post,I put my solution in bold!

more ▼

answered Jan 03 '19 at 12:13 AM

avatar image

r0stro
10 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question