x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

ERROR: No 32-bit compiler toolchain found in Visual studio

I got this error and i google, I tried their solutions but none worked. Like everytime i have faith that epic will not answer to my this question but i have nothing left to search for. How do i solve this error?

Product Version: UE 4.19
Tags:
more ▼

asked Aug 21 '18 at 12:42 PM in Installation & Setup

avatar image

Sanket Varia
11 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Ok i got the solution. Its very simple, I opened up a blueprint template project then i went to Editor Preferences -> General -> Source Code and choose Visual Studio 2017 in the Source Code Editor setting. Then i closed UE4 and retried creating the C++ project and it worked.

more ▼

answered Aug 22 '18 at 07:28 AM

avatar image

Sanket Varia
11 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Well ill give it a whirl.

  1. Pass in your system specs

  2. OS, and if your using 32bit or 64bit

  3. Any screen shots of the errors

  4. any other major details of installing you've done, such as: have you installed all of the proper c++ componets

  5. I am assuming a c++ project

Lets start here. sometimes its the details that make or break a question.

more ▼

answered Aug 21 '18 at 01:27 PM

avatar image

GIGA-Money
237 2 11 6

avatar image Sanket Varia Aug 21 '18 at 01:34 PM

I don't know what kind of spec you want but I have win 10 pro x64. its a laptop with i7 6th gen, 8GB RAM... UE4.19.2 and VS2017. here is the screenshot of error: https://imgur.com/pMPEc0Y OK little background of my laptop, I previously had unity3D because of which i had VS2015, Before installing VS2017 i made sure to uninstall 2015 but I still think perhaps my unreal is looking for 2015 files. I mean i don't have this error on my desktop computer, it too uses VS2017.

avatar image GIGA-Money Aug 21 '18 at 02:35 PM

Well I believe you have the issue that I suspected. Just a side note first, your in the world of c++ so you need some "extra" tools to work in the realm, comes with the territory. so I have had similar issues, and when you create a c++ unreal project the very first thing it has to do is compile the source code, as in unreal's source code. Don't worry why, but do the following and let me know how it goes.

  1. there are SDKs that are used for the c++ compiling

  2. launch the VS installer program.

  3. Be make sure that the actual VS is closed as these are not the same program and the VS installer will complain if VS is running.

  4. down load the particular SDKs as seen in the first likn

  5. https://docs.unrealengine.com/latest/INT/Programming/Development/VisualStudioSetup/

  6. Then Follow these steps 7.https://docs.unrealengine.com/latest/INT/Programming/Development/VisualStudioSetup/UnrealVS/index.html

avatar image Sanket Varia Aug 21 '18 at 03:42 PM

Nope, Nothing happened. Still the same error. Just in case for your information, Unreal engine is not creating the project itself if chose C++ template. So that means i can create blueprint templates, but i can't create C++ templates, not even the blank C++ template. I have installed that SDK long ago, still i double checked, yes its installed already.

avatar image GIGA-Money Aug 21 '18 at 05:58 PM

Well from a BP start up you can make it a C++ project. Do this by RMB the unreal project file, and you will see an option for Generate VS project file. then you can open it up in VS and see if you get an new compile errors.

avatar image Sanket Varia Aug 22 '18 at 05:26 AM

I right clicked on project it gave me only this options: Open, Show in folder, Create Shortcut, Clone, Delete.

avatar image Sanket Varia Aug 22 '18 at 07:26 AM

Nevermind i solved the problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question