x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Why isn't my particle emitter spawning consistently?

alt text

I'm throwing breakable items onto a flattened part of my landscape. At first I thought maybe it's falling slightly under the landscape and spawning the emitter there but at z2838 - no splash z2837 - splash

This was in one session but now the issue does seem to be consistent, every time I launch from the Level tab, it works every time. If I use the play button in a blueprint tab, the emitter fails to spawn every time...

It seems like opening or closing editor tabs may be responsible for that more consistent behaviour turning on or off... I just had another session (launched from Level tab) with one spawning a splash and one not, then it went back to consistently working as long as I launch from the Level tab again.

After restarting the editor, now splashes sometimes spawn when the game is launched from non-Level tabs and I haven't seen them fail in several tests from the Level tab.

What is going on!?

Here's part of the emitter setup in case it helps: alt text

EDIT: I forgot to mention the nodes before and after the emitter always work.

Product Version: UE 4.20
Tags:
capture.png (100.7 kB)
capture.png (184.4 kB)
more ▼

asked Aug 23 '18 at 12:23 AM in Blueprint Scripting

avatar image

HallwayWalker
20 4 3 7

avatar image Tuerer Aug 23 '18 at 08:26 AM

I think I might know what the issue is. Particle emitters have Bounds (I can't tell you now where to find it, somewhere in the emitter component settings). If you leave the Bounds default, the particles would sometimes disappear because of the garbage collector that sometimes considers them garbage, especially if the camera looks away. I had a similar issue with a laser - it would randomly disappear, but setting the Bounds to extreme values like 100000 fixed it. I don't have access to the editor right now, so can't provide any screenshots. Try looking for something like that in the emitter settling.

avatar image HallwayWalker Aug 23 '18 at 12:14 PM

Yeah that seems right. I made it a regular sprite instead of GPU sprite since I'm only using the exact particle limit of regular sprites and they don't use bounds. So far it works every time. I'll have to keep that in mind if I ever need GPU sprites I guess. Still weird that it depends where I launch the game from (IIRC, I even tried launching a standalone window from the Level tab and it worked the same as the default, unlike standalone windows launched from other tabs).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question