Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[Compile Error] missing include files (IntelliSense)

Some days ago I tried to upgrade my project from UE 4.19 to 4.20.1. I was one of those people who had to wait for 4.20.2 because of the missing IntelliSense links for the include files. But this still does not work. I use VS 2017 as it is recommended for 4.20+.

I get over 1000 errors from IntelliSense like cannot open source file "AssetBundleData.generated.h". How do I fix this very annoying bug? The compiler output also mentions a file called new in ue_4.20\engine\source\runtime\core\public\HAL/PlatformCrt.h(5) which does not exist. Does this refer to the same issue?

Product Version: UE 4.20
more ▼

asked Aug 23 '18 at 09:02 AM in C++ Programming

avatar image

44 3 54 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Right click on the UE4 project file -> Generate Visual Studio project files.

If this does not help:

  1. Delete the folders: .vs, Binaries, Build, Intermediate and Saved.

  2. Delete .sln file.

  3. Right click on the UE4 project file -> Generate Visual Studio project files.

  4. Open the .sln file and compile

more ▼

answered Aug 24 '18 at 03:40 PM

avatar image

191 6 6 13

avatar image MyFreshP Aug 24 '18 at 04:03 PM

This solved the issue for the *.generated.h files not being found by IntelliSense. Thanks! But I still encounter the issue with the file new mentioned in ue_4.20\engine\source\runtime\core\public\HAL\PlatformCrt.h(5). How do I solve this issue?

avatar image Takao_ Aug 24 '18 at 04:14 PM

Open that file, go to line 5 and post a screenshot or see for yourself if you can see what the error there is. I have there #include and that file is under:

 S:\Program Files (x86)\Visual Studio 2017 Community\VC\Tools\MSVC\14.15.26726\include\new
avatar image MyFreshP Aug 25 '18 at 08:35 AM

The line in question is #include <new>

And the error message I get is Cannot open include file: 'new': No such file or directory

I have such a file at the location you pointed out. But I do not know why VS does not know that this file is meant.

avatar image Takao_ Aug 25 '18 at 09:31 AM
  • Can you compile your project?

  • Try create another C++ project. Does this error also occur there?

avatar image MyFreshP Aug 25 '18 at 10:30 AM

I cannot compile any project due to this error. Even completely new created projects do not compile.

avatar image Takao_ Aug 25 '18 at 02:07 PM

The error message indicates, that the file is not in the include search path. This path should be added when you create the VS project file.
This means that this is either a VS or UE bug.
You can manually add the file path in VS:
Right click on the project (NOT solution) in the Solution explorer -> Properties -> NMake -> Include Search Path -> Edit -> New Line

avatar image MyFreshP Aug 25 '18 at 03:21 PM

The path was actually included. But apparently it did not work. I deinstalled and reinstalled VS and now it works. Thank you very much!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey, for people who is having problems with IntelliSense, my problem might help some others. My IntelliSense was working on x86 but not x64

I tried everything to solve it but what had really happened was that I had overwritten the file "C:\Users\username\AppData\Local\Microsoft\MSBuild\v4.0\ Microsoft.Cpp.x64.user.props" with the content from a colleague to build other project.

I added these lines which are the ones which screwed up my x64 Intellisense...

<ItemDefinitionGroup> <ClCompile> <AdditionalIncludeDirectories> <\AdditionalIncludeDirectories> <\ClCompile> <\ItemDefinitionGroup>

So all I had to do was to REMOVE THEM

more ▼

answered Mar 14 '19 at 08:33 AM

avatar image

1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question