x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

PrimaryDataAsset Blueprint Object Reference lost after Editor restart

Hey,

I worked on a Dialogue-System prototype and the DataAssets seemed to come in handy. But now I have a problem with this. I'm using UE 4.20.2 and I'm working in a blueprint project.

What I did:

  1. Created a new Blueprint Class derived from PrimaryDataAsset (BP_Conv)

  2. Openend it up and added some variables, nothing fancy here, only some Name-Variables. Save & Compile

  3. Created a new DataAsset (Rightclick - Miscellanous - DataAsset)

  4. Picked the derived Blueprint Class as the asset's class (BP_Conv)

  5. Created a new Blueprint Class derived from Actor (BP_DialogueTest)

  6. Added a new Variable of the type BP_Conv and made it public

  7. Hit Compile & Save.

  8. Dragged an Instance of BP_DialogueTest into the Scene

  9. Assigned a reference of the previously created DataAsset to the Instance.

  10. Run the game, everything worked fine.

  11. Restarted the Editor

  12. The DataAsset isn't referenced by the instance of BP_DialogueTest anymore.

I can reproduce this with my current project and with a fresh one. Is there any limitiation I missed or is this a bug? I really appreciate any help on this matter.

Thanks in Advance and best regards! Dekurian

Product Version: UE 4.20
Tags:
more ▼

asked Aug 23 '18 at 08:21 PM in Blueprint Scripting

avatar image

Dekurian
6 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Nevermind. Just found the solution to the problem after getting some sleep.

I flagged the derived class BP_Conv as abstract in the Class Settings, because originally I intended BP_Conv to be a base class for different kinds of conversations.

For testing purposes I created a DataAsset from the base class BP_Conv. Oddly enough this was no problem for the engine, which shouldn't be possible.

However referencing the instance of the DataAsset which was created from an abstract class lead to the problem I had. I simply removed the abstract flag, now everything works as intended.

Consider this post closed, but if you don't mind please consider having a look at the DataAsset Instancing behavior. An abstract class should not be able to be instanced like this.

Thanks in advance and have a good one

more ▼

answered Aug 24 '18 at 12:19 PM

avatar image

Dekurian
6 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question