x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE-62606: Confirmed 4.20 bug for focus on TextFields (only shows up in packaged builds)

Found this bug (UE-62606) in the bug database, and it matches our own experience:

https://issues.unrealengine.com/issue/UE-62606

Our widget components for in-world UI are no longer accepting focus for keyboard input in packaged builds. Calls to blueprint nodes "Set Input Mode UI Only" or "Set User Focus" do not result in a text field being focused, or responding to keys pressed. Running in-editor gives the expected results. We've confirmed that this problem did not exist in 4.19, and begins once importing it to 4.20. We also see the same problem with a fresh proof-of-concept project in 4.20.

This feature is essential for UI in VR. We use it for the experience moderator entering the user's email and name at the beginning of an experience.

Product Version: UE 4.20
Tags:
more ▼

asked Aug 27 '18 at 06:32 PM in Bug Reports

avatar image

thegiffman
31 1 9

avatar image uced Aug 27 '18 at 06:48 PM

Same problem here, good to hear they're aware of it.

I had a similar issue with buttons and it led to this ticket:

https://issues.unrealengine.com/issue/UE-62154

So this looks like a general issue with 3D widgets, and a big one. I hope they fix it fast, my game is entirely unusable when packaged. I've already lost weeks and given the work i already did with 4.20 i can't go back to 4.19, this is quite frustrating.

avatar image thegiffman Aug 27 '18 at 08:14 PM

Yeah. I wasn't much fun to be around this last week at work - it really took me about this long to track down what was causing this. It was kind of a perfect storm of obfuscating variables (our first multiplayer project, initially only showing up on the "client" so I thought it was a multiplayer issue, etc.) Nice to see that it wasn't just me.

avatar image thegiffman Aug 28 '18 at 01:55 PM

In the meantime, let me know if you find a workaround. I'd love to have a way to move forward in 4.20

avatar image uced Aug 28 '18 at 02:27 PM

For the buttons, you can use OnPressed instead of OnClicked, but no idea about other widgets.

Source:

https://answers.unrealengine.com/questions/813093/420-3d-widgets-non-clickable-in-standalone-game.html

avatar image thegiffman Aug 28 '18 at 02:29 PM

Doesn't help much with typing into text fields though. We'd literally have to write our own keyboard logic and manipulate the string value of the text field.

avatar image thegiffman Aug 31 '18 at 03:42 PM

I've got a workaround! Try this:

alt text

I also have a widget interaction component always pointing at it. But the combination of Slate.EnableFastWidgetPath, the interaction component, and the delay before setting focus does the trick!

image.png (136.4 kB)
avatar image uced Aug 31 '18 at 04:15 PM

Oh wow, this is gold, a thousand bravos and thanks !

As a test on my game, once in standalone, i just opened a console and typed de slate command manually, and it worked.

So maybe that's enough ? Did you try to simply delay the console call and doing nothing else ? Or execute the console command after the widget setup ?

Thanks again for finding and sharing that !

avatar image thegiffman Aug 31 '18 at 04:41 PM

I needed the delay between the console command and the call to setting focus - something about the initialization order.

I can't take total credit - there was a contact at Epic that helped us. I had tried both the delay and the fast widget path idea, but never both at the same time. ;-)

You definitely need to set focus after the console command and not before. But that command only needs to be done once - at the beginning of your application.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question