x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android Publish - Black Screen on Distribution Build

I have a game I'm trying to get into alpha testing on Google Play. When I publish straight to my phone from the editor it works fine. But when I build for Android I get my splash screen and then just black.

My game is small enough that I don't need an OBB but I have tried generating and uploading the OBB in addition to the APK. Neither work, same black screen.

Installing via the generated batch file or by downloading from Google Play doesn't seem to make a difference, both give me the black screen.

I have the NDK set to android-19 and the SDK set to latest. I've flipped on and off about every option I can think without luck. I have Google Play support checked. I'm pretty sure I have my app ID and license key both in correctly but I could be wrong about that. Not sure if that would cause this black screen issue, though.

I ran the NVPACK monitor.bat when trying to install/run my game and I didn't see any errors but I'm also not super familiar with how to work that - I just selected all logs during my testing and then searched for "error".

I can't think of what else it could be but this is my first time publishing a game. I've found a few posts about similar errors but all were resolved with methods I tried and none of them worked. I'd be happy to post any logs/screenshots to help determine if this is a bug or something on my end.

Thanks!

Product Version: UE 4.20
Tags:
more ▼

asked Aug 27 '18 at 07:16 PM in Bug Reports

avatar image

Thokash
1 1 4

avatar image Thokash Aug 27 '18 at 09:58 PM

I've also attached the log using monitor.bat. Still can't get it to work.

log.txt (94.8 kB)
avatar image Jadturentale Aug 28 '18 at 12:06 AM

Argh, f*cking problems on Unreal Engine. Y'know what? I'm gonna try to help then. Maybe your Android device does not work properly, or maybe your android device is too weak to support UE4.

avatar image Thokash Aug 28 '18 at 12:16 AM

I don't think it's that, I'm running on a Galaxy S8. Plus, when I "Launch" to my phone from editor it works beautifully. It's only when I have a full distribution build that I install using either Google Play or the .bat file.

I'm wondering if it involves Android permissions at all.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I've seen this answer dozens of times trying to resolve this issue but all it took was remembering to set the default game map.

It's worth noting, though, when you launch from the editor to a device the default map is the editor default, not game. It's not game default until the actual game is packaged.

more ▼

answered Aug 28 '18 at 12:34 AM

avatar image

Thokash
1 1 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question