x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.20 Build Error

Hey gang, just updated to 4.20.2 and started a build w the following error;

UATHelper: Packaging (Windows (64-bit)): LogNavigation: Error: [/Script/Engine.RecastNavMesh] found in the DefaultEngine.ini file. This class has been moved. Please rename that section to [/Script/NavigationSystem.RecastNavMesh] PackagingResults: Error: [/Script/Engine.RecastNavMesh] found in the DefaultEngine.ini file. This class has been moved. Please rename that section to [/Script/NavigationSystem.RecastNavMesh]

What is this and how do I fix it? Thanks for any help! I am not currently using VS.

Product Version: UE 4.20
Tags:
more ▼

asked Aug 27 '18 at 07:26 PM in Packaging & Deployment

avatar image

JRV1
1 1 3 4

avatar image SuperfuntimesV Feb 14 '19 at 04:10 PM

I'm getting this error but it's already /Script/NavigationSystem.RecastNavMesh... Build 4.21...

My DefaultEngine.ini already has:

[/Script/NavigationSystem.RecastNavMesh] CellSize=8.000000 AgentRadius=28.000000 AgentMaxStepHeight=50.326584 AgentMaxSlope=76.209518

There's no instance of the old scripting in the text file but I'm getting the error anyway.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

It says right there in the message:

Please rename that section to [/Script/NavigationSystem.RecastNavMesh]

So just open DefaultEngine.ini (in your Config directory) in any editor and replace

[/Script/Engine.RecastNavMesh]

with:

[/Script/NavigationSystem.RecastNavMesh]

more ▼

answered Aug 28 '18 at 06:32 AM

avatar image

erikdubbelboer
386 3 4 8

avatar image JRV1 Aug 28 '18 at 03:59 PM

I am not a smart ma'yan. =) Thanks.

avatar image erikdubbelboer Aug 28 '18 at 04:37 PM

Please mark my answer as correct, thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Try clicking on the down arrow next to UE 4.20 and verifying the files if that doesn't work you might try reinstalling

more ▼

answered Aug 27 '18 at 07:33 PM

avatar image

FlickMastaBean
6 1 2

avatar image JRV1 Aug 28 '18 at 01:24 AM

Neither worked. Any other suggestions?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question