x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Reflection captures need to be rebuilt message is only visible in standalone or in a packaged build

The message warning to rebuild the reflection captures is only on screen in standalone mode and on a packaged built but it doesn't say anything in PIE. The reflections are being shown correctly inside the editor and in a standalone/package.

This is happening after I changed the version from 4.19 to 4.20. I tried to rebuild the reflections captures inside the editor but the message it is still there. Before changing the version I deleted all the intermediate folders to avoid having problems with something outdated.

I don't know what else to try.

Thank you for your help

Product Version: UE 4.20
Tags:
more ▼

asked Aug 27 '18 at 10:14 PM in Packaging & Deployment

avatar image

MightyPolygon
6 1 2 2

(comments are locked)
10|2000 characters needed characters left

5 answers: sort voted first

Hi, I have experienced the same issue. The way I fixed it was moving all the SphereReflectionCapture from the sublevels to the PersistenLevel and then rebuilding the reflections once again. Also, make sure the amount of SphereReflectionCapture are less than 341 If it doesn't work, try deleting all the reflection captures and the creating them again.

more ▼

answered Oct 29 '18 at 01:00 PM

avatar image

raliar
6

avatar image Weibye Mar 05 '19 at 01:06 PM

Was having the same issue in 4.21.

The way I fixed it was moving all the SphereReflectionCapture from the sublevels to the PersistenLevel and then rebuilding the reflections once again.

This fixed it for me.

(comments are locked)
10|2000 characters needed characters left

I'm having the same problem. I am also in 4.20 but I haven't verified that making the switch to 4.20 was the issue.

It definitely appears like the reflection captures are working so I ended up just disabling the on screen messages for each level that the issue persists.

So just add a Execute Console Command node at your Event Begin Play and then use the console command "DISABLEALLSCREENMESSAGES".

Sorry I don't have a better answer.

more ▼

answered Aug 28 '18 at 01:15 PM

avatar image

Jonas M
1 1 2

avatar image MightyPolygon Aug 29 '18 at 04:13 PM

I am not sure if the issue was making the switch to 4.20 but in 4.19 the same levels worked fine.

Yes, it seems that the reflection captures are working which is weird. I am worried that this might cause other problems but so far everything works fine.

Your trick works to hide the message so at least is a temporal fix. I will try to look into it and if I find the source of the problem I will let you know over here.

(comments are locked)
10|2000 characters needed characters left

Same Problem here

more ▼

answered Sep 04 '18 at 05:45 AM

avatar image

Shleezy
1 1

(comments are locked)
10|2000 characters needed characters left

A solution that worked for me is to package the game for shipping not for development. You will find the option under: File_PackageProject_BuildConfiguration. Hope this helps.

more ▼

answered Sep 05 '18 at 01:20 AM

avatar image

Shleezy
1 1

avatar image MightyPolygon Sep 05 '18 at 03:07 PM

Yeah, in shipping all the screen messages disappear by default but if something is not working properly it will stay there. I haven't made any test yet but it may affect performance if is making extra checks. Right now it could serve as a workaround but we personally need development builds for internal testing.

(comments are locked)
10|2000 characters needed characters left

This looks to be caused by the CubemapSize = 0; set in FReflectionCaptureData::OnDataUploadedToGPUFinal in MapBuildDataRegistry.h The query for the reflection data is failing due to the CubemapSize not being the expected size. I have pulled it, and reflection reflection captures are back to working.

more ▼

answered Sep 21 '18 at 09:39 PM

avatar image

jasoncalvert
16 1

avatar image Shleezy Sep 21 '18 at 10:40 PM

Hi, what do you mean by "pulled it"?

avatar image jasoncalvert Sep 22 '18 at 12:22 AM

I removed it. It's no longer set to zero on UploadToGPUFinal.

avatar image Shleezy Sep 22 '18 at 06:11 PM

I am pretty new to UE4 and not quite sure how you have solved this problem. Would you mind to provide a step-by-step solution.Thx!

avatar image MightyPolygon Sep 24 '18 at 09:05 PM

Hi, I haven't had the chance to test this solution yet but knowing the issue it seems like a bug in the engine code, have you reported it as such so they can fix it or send a pull request? In my case making changes in the engine code is an issue as I am not distributing a custom build version to my team. Thank for the info.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question