x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Spring Arm with camera lag still stiff

I have a SpringArm setup to follow a car and it works OK except for the fact that no matter how much Camera [Rotation] Lag Speed I put in it won't properly work. When I turn the car, the camera stays fixed on the chassis - making it look awkward -- the car needs to rotate a bit before the camera starts following it.

Use Controller View Rotation is off, I'm inheriting from all axes, Enable Camera Lag is on (Rotation as well) with various big values put in. This is a problem for the Vehicle Game 4.2 example project.

What am I missing?

Product Version: Not Selected
Tags:
more ▼

asked Aug 11 '14 at 10:25 PM in Blueprint Scripting

avatar image

valentingalea
5 1 1 1

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

The scalar you give for lag seems to work in the inverse. I find 10 gives good results for the speed of my game and 5 is too much lag to play well

more ▼

answered Sep 13 '14 at 10:03 AM

avatar image

rodstone
76 11 16 90

(comments are locked)
10|2000 characters needed characters left

Hei, I had the same problem; the camera moved instantly whatever value I set for CameraRotationLagSpeed, on my USpringArmComponent. Turns out I didn't set bEnableCameraRotationLag and that needs to be set to true.

Also, larger values of CameraRotationLagSpeed make your camera lag less, like @rodstone already said in his reply... years ago. I'm not surprised if this comes a little too late for you, @valentingalea, but hopefully it's useful for someone :)

more ▼

answered Jan 18 '17 at 07:32 PM

avatar image

amcofi
505 9 83 48

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question