x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Tutorial 3 Error

Hello Everyone,

so im following this tutorial but i can't quit get my OnPickUp_implementation function correct, which prevent me from debugging. here is the link: http://www.youtube.com/watch?v=ZPn4N3ckP8I

I've double check the names and such i can't see my error.. (Code Attached)

im so new to the programming in UE4 im not new to C++ so im kinda lost here..

if anyone would suggest another good learning start would be so grateful.

Regards, MrHero

alt text2493-untitled.jpg

Product Version: Not Selected
Tags:
untitled.jpg (163.8 kB)
more ▼

asked Aug 11 '14 at 10:36 PM in C++ Programming

avatar image

MrHero
51 2 6 7

avatar image Duncan Dam Aug 12 '14 at 07:33 AM

i don't see any link on your tutorial.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

So i've solved the problem i managed to build and run the debug successfuly but i don't quit get to understand what was wrong with it..

what i did is just made a new project and rewrote everything and it worked.. even though i get a red line under the OnPickUp_Implementation part..

here is a photo with the correct Code:- alt text

untitled.jpg (276.9 kB)
more ▼

answered Aug 13 '14 at 11:28 AM

avatar image

MrHero
51 2 6 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I don't really understand your problem.

Comparing your screenshot with the Tutorial i only see, that you need to write

 UFUNCTION(BlueprintNativeEvent)
 void OnPickUp();

in the .h File and than you can go and write

 void APickup::OnPickUp_Implementation()
 {
 // There is no...
 }

Into your .cpp file.

If you get an error, please post the error/log file. (:

more ▼

answered Aug 12 '14 at 11:42 AM

avatar image

eXi
6.8k 333 185 468

avatar image MrHero Aug 12 '14 at 01:41 PM

sorry the screenshot was just me testing removing the Blueprintnativeevent and the _Implementation.. but i had them on as shown below with the error log, im not sure how to file the error log but i hope this one is what u asked for :- alt text

  Error    1    error : In Pickup: Unknown variable specifier

'catogery' C:\Users\Haroon\Documents\Unreal Projects\LearningProcess\Source\LearningProcess\Public\Pickup.h 16 1 LearningProcess Error 2 error code: 2 C:\Users\Haroon\Documents\Unreal Projects\LearningProcess\Intermediate\ProjectFiles\Error LearningProcess Error 3 error MSB3073: The command ""C:\Program Files\Unreal Engine\4.3\Engine\Build\BatchFiles\Build.bat" LearningProcessEditor Win64 DebugGame "C:\Users\Haroon\Documents\Unreal Projects\LearningProcess\LearningProcess.uproject" -rocket" exited with code -1. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets 38 5 LearningProcess

![alt text][2]

untitled.jpg (266.7 kB)
avatar image MrHero Aug 12 '14 at 01:43 PM

i also get this while running the project in the UE4 Launcher

!Id:54cc4db6e842e39fd52e2ff8e662bf28

Access violation - code c0000005 (first/second chance not available)

Fatal error!

UE4Editor_Engine + 9049160 bytes UE4Editor_Engine + 2395910 bytes UE4Editor_CoreUObject + 1001061 bytes UE4Editor_CoreUObject + 1170269 bytes UE4Editor_CoreUObject + 731562 bytes UE4Editor!TBaseMulticastDelegate_NoParams::Broadcast() + 128 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.3\engine\source\runtime\core\public\delegates\delegatesignatureimpl.inl:1852] UE4Editor!FEngineLoop::AppPreExit() + 353 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.3\engine\source\runtime\launch\private\launchengineloop.cpp:2529] UE4Editor!FEngineLoop::Exit() + 278 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.3\engine\source\runtime\launch\private\launchengineloop.cpp:1944] UE4Editor!GuardedMain() + 529 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.3\engine\source\runtime\launch\private\launch.cpp:144] UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.3\engine\source\runtime\launch\private\windows\launchwindows.cpp:125] UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.3\engine\source\runtime\launch\private\windows\launchwindows.cpp:207] UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

avatar image eXi Aug 12 '14 at 02:15 PM

I can't see the screenshots. Only the one that has a link and there you didn't wrote

 void APickup::OnPickUp_Implementation()


in you .cpp file.

i can't get much out of these errors :/

Is there more of the first error?

avatar image MrHero Aug 12 '14 at 07:05 PM

uhh sorry with the photo .. the 1st error is just saying that there were build error then i get this:- Note: i already wrote the _Implementation there but it still underlines it with red ..

http://po.st/QQK7jh

i uploaded the photo in imageshack.us just in case ^^

sorry for the disturbance, regards, MrHero

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

On the bIsActive variable in your header file, the UPROPERTY macro has a typo - catogery instead of Category. Does that fix allow you to compile?

more ▼

answered Aug 12 '14 at 03:41 PM

avatar image

Shadow.Storm STAFF
253 4 7 17

avatar image MrHero Aug 12 '14 at 08:32 PM

even thou i Quad-checked it D:.

though it still doesn't fix my problem ,, it wont allow me to compile yet ..

avatar image Shadow.Storm STAFF Aug 12 '14 at 08:38 PM

One step closer! :)

What error are you getting now?

avatar image MrHero Aug 12 '14 at 10:12 PM

i still get the same compilation error and the same errors in the description, the ones i posted here :- http://po.st/QQK7jh back there ^^

avatar image MrHero Aug 12 '14 at 11:27 PM

I'm not sure how this will Help but i made a new project and new name for the Actor and the project itself hoping it would be different this time, but instead i get errors on the main codes likes the #include and TSubobjectPrt and stuff.. here is a picture..

http://po.st/WLS713

avatar image eXi Aug 13 '14 at 01:19 AM

Please show us the errors after you fixed the "catogery" mistake (: Even if they are the same. And the second picture with your new project got an error at the USphereComponent line. The "S" of Sphere must be capital. But please lets stay with the first version. Fix the spelling mistake Lauren Ridge found and show us new picture of the errors and/or the log file. (:

We will get this working again (:

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question