x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging a plugin in 4.20.2 fails

Hello,

I have a plugin that in the past I have distributed for engine versions 4.16, 4.17, and 4.18.

Nothing was different about the plugin in any of these builds but now in 4.20 I cannot get the packaging process to complete without an error.

I have no issue building the source of my plugin into an empty project (clicking build in visual studio results in 2 builds successful, one for the plugin and one for the empty host project.)

When I then open that project in the editor and try to package the plugin I get errors.

I have attached in a zip file:

1) Two output logs from the packaging process. 2) The .uplugin file that always worked in past engines 3) the Build.cs file for the plugin that always worked in past engines.

Zip File

Update: The packaging works as is in 4.19.2 as well.

Product Version: UE 4.20
Tags:
more ▼

asked Aug 28 '18 at 05:40 PM in Packaging & Deployment

avatar image

JWizlo
1 2 2

avatar image j.mueller RFG Aug 29 '18 at 02:33 PM

The log complains about missing includes ModuleManager.h in ArenaLiveAPI.h and EnumProperty.h in BlasterEnums.h. If it is guaranteed that these headers are present and thier include paths are properly set, have you already tried to do a clean rebuild?

avatar image JWizlo Aug 29 '18 at 02:48 PM

I am under the impression that setting the include path is what I am missing. The header files in question are located with the engine.

In the past I'm pretty sure the include path was set correctly by adding the dependency module, "CoreUObject," to the build.cs file for the plugin, but that is not working as it had in other engine versions. Rebuilds have not changed the outcome.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

The fix was to find each include directive which referenced a file in UObject or Core and add parts of the path after "Public"

 #include "EnumProperty.h"

becomes

 #include "UObject/EnumProperty.h"

more ▼

answered Aug 29 '18 at 07:28 PM

avatar image

JWizlo
1 2 2

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question