x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Project crashes on startup (4.3) - Unrecoverable

After working for hours on my project it now crashes on startup. I cannot do anything and need help. The contents can be found here:

http://1drv.ms/1oEKQhk

My settings are set to load the last map which is "persistent.umap"

  • jeff

Product Version: Not Selected
Tags:
more ▼

asked Aug 11 '14 at 11:06 PM in Bug Reports

avatar image

jeffvoigt
423 19 37 63

avatar image jeffvoigt Aug 12 '14 at 09:43 PM

In order to help troubleshoot this error I'm running on the 4.3.1 code branch with a modified LinkerLoad.cpp file. It was modified to address my previous issue that was resolved a few weeks ago. The code change is documented here:

https://github.com/EpicGames/UnrealEngine/commit/b83dd1f4277b46dc8a2a7e17b22c5ec45f8d6f74

Here is link to the LinkerLoad.cpp file: http://1drv.ms/1q786AU

Here is a link to the call stack dump from the exception: http://1drv.ms/1q78e3m

Thank you, - jeff

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I did what was mentioned I removed and recreated from scratch the CharmState and CharmSave blueprints. I was able to get past the error. We are now stuck on another show stopping crash that was posted a week ago found here:

https://answers.unrealengine.com/questions/92641/multiple-441-errors-with-stepsscreenshots-unable-t.html

Was hoping a developer could guide us as we cannot keep removing/recreating files.

Thank!

more ▼

answered Sep 09 '14 at 02:04 PM

avatar image

jeffvoigt
423 19 37 63

avatar image Tim C ♦♦ STAFF Sep 09 '14 at 04:02 PM

Sorry for missing your other post. I have assigned it to myself and have started some preliminary investigations into the issues that you described there.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi jeffvoight,

Sorry to hear that you are having an issue. At least for starters we'd like to be able to get you back inside your project, and we can probably do that by having you open to a different default map.

Go to Unreal Project/YOUR_PROJECT/Config

Open up DefaultEngine.ini

You will see a line that says EditorStartupMap= with the path to your persistent.umap

Remove the line, save the file, and try opening your project. Hopefully from here to can try to identify a troublesome asset and pull it out if necessary. One of our support engineers has been asked to look into the issue and will see if they can determine any other information.

I hope this helps.

more ▼

answered Aug 13 '14 at 06:43 PM

avatar image

Stephen Ellis ♦♦ STAFF
11.5k 322 32 480

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi jeff,

As Stephen mentioned, getting back into your project is not a big problem. I opened the DefaultEngine.ini file in your project and noticed that there were two EditorStartupMap=... lines there. If you delete the line referencing your persistent.umap level, save, and re-open the project, you will be able to get in again.

That was the simple part of the issue. Unfortunately, what I noticed when I was able to get into your project was that trying to open any level other than the default level, or trying to open a Blueprint, would cause the same crash to occur. I did not try every Blueprint or other asset that you have in the project, but every Blueprint that I did check caused a crash.

This does not appear to be related to the changes that you have made to your LinkerLoad.cpp file. I tried opening the project using versions of the Engine both with and without the changes to that file and saw the same crash in both. I am going to see if I can get someone on the development team to take a closer look at the callstack for clues to what is happening.

In the meantime, do you recall what you were last working on in the project before this issue started happening?

more ▼

answered Aug 13 '14 at 07:03 PM

avatar image Tim C ♦♦ STAFF Aug 13 '14 at 07:25 PM

I may have spoken too soon. I just discovered that there is one Blueprint that I am able to open: bp_board. After I have opened this Blueprint, I am then able to open all of the other Blueprints, and even load different levels. Until I close the project, which results in the crashes starting again the next time I open it.

I am still going to have a developer look at this, but at least it looks like you will be able to access your Blueprints and levels. I have not tried actually making any changes though, so I do not know what effect, if any, that will have.

avatar image jeffvoigt Aug 13 '14 at 09:41 PM

I narrowed it down to either the CharmState or CharmSave blueprints. I was able to revert to a previous version of those and it loaded fine. It is one of those blueprints. I just started to implement my saving when this all occurred.

avatar image Tim C ♦♦ STAFF Sep 08 '14 at 10:46 PM

Hi jeff,

I apologize for not responding to this sooner. Were you able to resolve the issue that you were experiencing?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question