x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Invisible collision or Physics bug? Please help

Procedurally generated spline mesh actors are "Weaved" together to make this track.. .anytime the physics ball hits one of the "seams" which doesn't show any collision as seen in the video it jumps... what gives? please help!

https://youtu.be/8uZ0mnTsrhQ

Product Version: UE 4.19
Tags:
more ▼

asked Aug 29 '18 at 01:02 AM in Using UE4

avatar image

Imagine-Games
224 5 11 15

avatar image IndieGameCove Aug 29 '18 at 02:40 AM

Does it only jump when it's on the spline mesh, or is it jumping on landscapes/static meshes as well?

avatar image Imagine-Games Aug 29 '18 at 04:09 PM

static meshes as well... i tried adding a bunch of cubes in a straight line and anytime the ball overlapped the next cube it jumped

avatar image dZh0 Aug 29 '18 at 06:17 AM

Your colliders are touching at 0 distance right? Try to overlap them a little bit and say how it went.

I know this is not a fix but I suspect rounding errors as the physics engine cuts a lot of corners when calculating.

Also try tinkering with the physics engine sub-steps. Try wildly higher or lower values and see if changes anything.

avatar image Imagine-Games Aug 29 '18 at 04:07 PM

i did try messing with substepping and setting it to max (16) to no avail.. the solution below that resolve my issue (the one messing with the simulation settings) overlapping the meshes did not resolve it, the collision still occurred whenever the overlap occured regardless of it being closer or further away(as soon as collision is on the next mesh it jumps)

avatar image Bykgames Aug 29 '18 at 06:50 AM

I am experiencing the exact same issue with my cars physics

avatar image dZh0 Aug 29 '18 at 08:12 AM

We got the same issue on one car project:

When the car scrapes the colliders on the side of the road and moves from one collision plane to the other it would occasionally be launched in low earth orbit. :)

I think the solution we used was to sweep the car collider get the hit position and move the car to that location before the physics kick in.

It was on in-house engine though, not UE.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I fixed this with a solution from BoredEngineer on Discord (Unreal Slackers) These settings below fixed the issues and made it playable: I only touched min and max contact and multiplier... alt text

boredengineer.png (19.6 kB)
more ▼

answered Aug 29 '18 at 03:56 PM

avatar image

Imagine-Games
224 5 11 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question