x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to view details of inherited mesh of c++

Hey all,

So I'm working on this FPS game and I have a c++ file called mannequin.cpp of type Character.

I've got a new character which my friend created, its parent class is of type character so switching over to mannequin.cpp shouldn't be a problem, and it compiles fine, but when I run the game it crashes.

The issue I think is one of the inherited meshes from the C++ source file does not display the mesh detail for some odd reason. I've left screen shots below I'd appreciate any help.

https://imgur.com/a/SV7CV3Y

Product Version: UE 4.19
Tags:
more ▼

asked Aug 29 '18 at 08:03 PM in C++ Programming

avatar image

GhettoBurger
21 2 6

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

You need to put EditAnywhere specifier on component pointer to make it editable in blueprints

more ▼

answered Aug 29 '18 at 09:32 PM

avatar image

Shadowriver
35.2k 921 166 1098

avatar image GhettoBurger Aug 30 '18 at 02:13 PM

It was originally set to VisibleDefaultsOnly I've changed that to EditAnywhere, I still get the same issue thought. One character works fine, the new imported one doesn't seem to want to display anything on the details tab

avatar image GhettoBurger Aug 30 '18 at 08:46 PM

hey I removed the code and added it again then recompiled then it somehow magically worked. Didn't need to change anything. Thanks for the help

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question