x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Issues cooking for distribution (development succeeds)

Hi all,

I'm getting an error when trying to package my project for distribution. It works absolutely fine on development packaging mode but when I switch to shipping it fails. These are the error messages that show up:

 UATHelper: Packaging (iOS):   LogShaders: Error: Archiving failed: Copy object file to remote failed for file:"../../../../Users/aless/Documents/Unreal Projects/NEurocub3R/Saved/Shaders/SF_METAL/ShaderDebug-Global-SF_METAL/NativeLibrary/SF_METAL/Main_00001f64_f5d9c2d2.o"
 UATHelper: Packaging (iOS):   LogShaders: Error: Archiving failed: no valid input for metallib.
 PackagingResults: Error: Archiving failed: Copy object file to remote failed for file:"../../../../Users/aless/Documents/Unreal Projects/NEurocub3R/Saved/Shaders/SF_METAL/ShaderDebug-Global-SF_METAL/NativeLibrary/SF_METAL/Main_00001f64_f5d9c2d2.o"
 PackagingResults: Error: Archiving failed: no valid input for metallib.
 UATHelper: Packaging (iOS):   CookResults: Error: Package Native Shader Library failed for IOS.
 PackagingResults: Error: Package Native Shader Library failed for IOS.

Has anyone received this shady error related to the native shader library / metallib before? Any ideas of how to solve it?

Background: I'm running version 4.20.2 of the engine compiled from source on a PC, and using a remote mac for compiling to IOS.

Thanks in advance

Product Version: UE 4.20
Tags:
more ▼

asked Sep 01 '18 at 06:43 PM in Packaging & Deployment

avatar image

Al Ananias
225 6 10 17

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Resolved: The issue was that I was using a development provision with a distribution certificate. You need to remember to have the distribution version of both the certificate and the provision in the Apple developer portal.

more ▼

answered Sep 03 '18 at 10:42 PM

avatar image

Al Ananias
225 6 10 17

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question