x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to make TextRenderActor render specific letters?

I am trying to localize game. I have successfully made localization, set culture in game and imported custom font. Currently I am stuck with TextRenderActor not being able to represent specific latin letters.

Here is example (it should output "TEST ŠĐČĆŽ"): TEST ŠĐČĆŽ

As you can see, I am getting squares instead of those specific letters.

Font that I am using supports these letters (I tried in LibreOffice Writer to write same text and select font that I am using in Unreal Engine).

Here is example from LibreOffice Writer: TEST ŠĐČĆŽ from LibreOffice Writer

I have tried to switch (in Font) Character Set to all 3, but no luck.

Can someone point me what could be issue?

Product Version: UE 4.20
Tags:
more ▼

asked Sep 01 '18 at 08:56 PM in Using UE4

avatar image

Dragan
38 5 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Considering you import the font you should be very aware that fonts for text render component need to be baked in to texture using "Offline" import mode and importing all Unicode characters is expensive. By default the font Offline importer create textures for for Basic Latin and Latin-1 Supplement, but you can tell it to include more, the letters you trying to use are sitting in Latin Extended A.

Go to font asset and see "Import Options" there should be "Unicode Range" this is where you paste in extra ranges you want it to import, it numbers can be written in hex and range marked with "-" and multiple ranges separated with comma. Now do to some site that shows unicode table like this one:

https://unicode-table.com

And look for range oyu looking for, in your case Latin Extended A is 0100-017F so paste that there. Then right click the font asset and hit "Reimport" and you done

There also 2nd option, in "Chars" parameter you can explicitly list characters that you want it to import, but keep in mind it will only import those characters so you need to include everything that you gonna use including Basic Latin range.

Angain everything you change in "Import Options" need to be confirmed with "Reimport" to be applyed

more ▼

answered Sep 01 '18 at 10:52 PM

avatar image

Shadowriver
37.3k 936 172 1116

avatar image Dragan Sep 02 '18 at 09:19 AM

Thank you so much, it is working now :)

Problem was that I haven't added that Unicode Range.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question