x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android Back button don't fire

Hello everyone! I has problem with using Android Back button in my Widgets. So, here a code alt text That a widget that take input and call event if that button we looking for. Backspace setuped for debug porpuses and its work fine, calling the event. But when i start build on Android system & use Back button, i didn't get anything.

When i looked for answer i also tryed to use Enable Input & Set Input UI Only (as on screenshot below), but that don't give anything to me.

alt text Any guesses how to fix the problem?

Product Version: UE 4.20
Tags:
1.png (94.3 kB)
2.png (61.0 kB)
more ▼

asked Sep 03 '18 at 02:06 PM in Blueprint Scripting

avatar image

GloryOfNight
66 3 6 10

avatar image GloryOfNight Sep 03 '18 at 03:13 PM

Additional info.

I tried to use Delay with 1sec on begin play (to let all element synchronize) - doesn't help

Tried to Change Text in widget (1st screenshot, on false), when any wrong button come - Text just doesn't changed at all when I press Android back

Widget 100% has focus in it, if that wasn't so Backspace button doesn't fire, but its fire.

avatar image GloryOfNight Sep 03 '18 at 03:26 PM

Additional test. Level Bpueprint alt text Tested with Backspace button on Mobile Preview & PIE, work alright. When I build it to mobile, nothing happen

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Changing in config DefaultEngine value bAllowControllers to True solve problem to me

more ▼

answered Sep 04 '18 at 01:11 PM

avatar image

GloryOfNight
66 3 6 10

avatar image Jimminy_Cricket Oct 25 '18 at 05:49 AM

This was driving me nuts, and changing what you mentioned in the config file fixed it. Thanks heaps!

avatar image GloryOfNight Oct 28 '18 at 06:52 AM

For addition, this bug will be fixed in 4.21 (As sayed in bugreport that I submited). So you can check how it works

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was having same issue on the blog. it seems like it was due to that i have reset the phone and some how it got fix. However, if you have same issue you should must visit this kodi addon post will give you high insights on it.

more ▼

answered Oct 28 '18 at 10:50 AM

avatar image

karanzale
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question