x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Localization text not showing

I have all of the localization translations setup in the localization dashboard. Code written and tested to change the culture. Gathering, compiling, exporting all run with no error......

So why does the text not change to the translated version in the game?? Been bashing my head off this one all day.

Product Version: UE 4.19
Tags:
more ▼

asked Sep 03 '18 at 06:54 PM in Packaging & Deployment

avatar image

Jiyko
34 5 8 9

avatar image Jamie Dale STAFF Sep 03 '18 at 07:59 PM

How are you testing? Packaged game, -game in the editor, or PIE?

avatar image Jiyko Sep 04 '18 at 11:35 AM

Thanks for responding, Jamie, but I fixed it.

For future intrepid adventures into the "experimental" world of the localization dashboard. - Was testing in packaged game and standalone - Internationalization support is set to 'all'.

The fix that seems to work for me was changing the target name to 'Game' as suggested in another tread. No idea how that worked ¯_(ツ)_/¯

avatar image Jamie Dale STAFF Sep 04 '18 at 02:00 PM

Ah, I'm guessing the dashboard had failed to add your target to your DefaultGame.ini file correctly (it's supposed to do it automatically).

You should have had something that looked like this in your DefaultGame.ini. "Game" always works as that's added to BaseGame.ini.

 [Internationalization]
 +LocalizationPaths=%GAMEDIR%Content/Localization/YourTarget

What was the "Loading Policy" of your target set to?

avatar image Jiyko Sep 05 '18 at 10:14 AM

That makes sense. Is there a UE bug logged for this? Will upvote if so.

It's now set to 'always', not sure what it was set to previously but remember thinking it looked different.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question