x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.20 broke my Depth Buffer

Edit

Turns out it's a bug! Check UE-64034 for progress on a solution. Thanks to everyone who helped me.

TL;DR

Unreal's renderer has been corrupted for me since 4.20 released. I suspect that there's something wrong with my depth buffer. Here's what the depth buffer looks like before and after entering VR.

alt text

In Detail

Sooo after updating to Unreal Engine 4.20 I've been having some issues making VR content.

Whenever I enter VR everything Unreal renders gets corrupted (even thumbnails!). Eventually I figured out that the scene depth buffer get messed up by entering VR. To fix this I can restart UE or take a 'High Resolution Screenshot'.

Best of all: Everything is fine in UE 4.19, and the preview builds of 4.20 also worked flawlessly. Some change in 4.20 probably broke my depth buffer.

At this point I've tried pretty much everything except for replacing my graphics card and reinstalling Windows.

I'd be happy about any suggestions! :]

Things I've tried

-Creating an empty project

-Reinstalling UE 4.20

-Updating my graphics card driver

-Rolling back my graphics card driver

-Deleting all sorts of derived data caches

-Making posts on the forum, the Answerhub, Reddit, the Unreal Slackers Discord, ...

-Not using DirectX (Actually works, but Vulkan and OpenGL crash frequently.)

-Using the forward renderer, using instanced stereo

Here's my DxDiag. https://pastebin.com/raw/a8pEGRVj

And here's an image of the renderer overview: Click me

Have I missed anything? Any comments appreciated!

Product Version: UE 4.20
Tags:
more ▼

asked Sep 04 '18 at 01:22 PM in Rendering

avatar image

daalta
18 1 5 7

avatar image ortroll Sep 04 '18 at 02:26 PM
avatar image daalta Sep 04 '18 at 05:23 PM

Thanks for the reply. That's actually my post as well. But I felt like I didn't describe the issue accurately since I've learned a couple new things. Thank you for your replies in that post as well.

I don't suppose you've seen any other threads with my issue?

Edit: I'm also having trouble getting replies. So far you're the only person who's replied to any of my question on the forum or Answerhub. Do you have any tips on getting more answers?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Edit: It's an AMD driver bug. Disable "Flags.bCompositeDepth" in "Oculus\OculusVR\Source\OculusHMD\Private\OculusHMD_Settings.cpp"

After the issue was marked as "Won't fix", as a last resort, I tried to find the bug myself.

I found it. So here it is. Reverse this commit and compile your own version of the Unreal Engine.

https://github.com/EpicGames/UnrealEngine/commit/bd51b2429fb5512e30d21d6e9199843c400c1557

Here are the instructions for getting GitHub access to the source code.

https://www.unrealengine.com/en-US/ue4-on-github

more ▼

answered Oct 14 '18 at 08:00 PM

avatar image

daalta
18 1 5 7

avatar image JUDGE DREDD VR Feb 05 '19 at 01:20 AM

After change OculusHMD_Settings.cpp meed only Build new Version or need Buiild sln?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Thank you for submitting a bug report. I have reproduced this issue and logged a report for it here https://issues.unrealengine.com/issue/UE-64034 You can track the report's status as the issue is reviewed by our development staff.

more ▼

answered Sep 12 '18 at 08:31 PM

avatar image

Alex O ♦♦ STAFF
2.8k 5 10 11

avatar image daalta Sep 12 '18 at 10:05 PM

Goodness. Thank you so much! Thought there'd never be a solution in sight. :)

Glad that the bug report reached you quickly.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question