x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Mobile Patching Utility Crash - Windows10 Package

I recently got a new computer with Windows 10 and I have transferred my project that started on a PC with Windows 7. I am running a blueprint project built from source. On the new PC I get the same crash with 4.19, 4.19.2 and 4.20.2.

On my Windows 7 PC the game runs and packages with no issues. I use the Mobile Patching Utility as a patcher. On the new computer with Windows 10 I can fully compile in Visual Studio 2017 and package the game with no errors. i use the Project Launcher tool to package.

When I start my game up it actually does not crash right away - I can get all the way to the file size check without crashing. Once the file size check passes, the game will crash which leads me to believe the "Start install" node is the source of the crash that ends with a fatal error() - see log file attached. In addition, if I force mount the patch, which skips the start install node, it will open and run without a crash.

The only difference other than the windows OS version that I can tell is the visual studio 2017 is more updated on the new PC at 15.8 compared to 15.5 on the windows 7 PC. I've verified my Visual Studio install includes Desktop C++, Game Development C++, .Net and also included the unreal engine install check box as well.

I can package the project on my Windows 7 PC and it will run on both computers. If I package on the Windows 10 PC it will crash on both computers. link text

Product Version: UE 4.20
Tags:
gamejam.log (30.6 kB)
more ▼

asked Sep 05 '18 at 04:41 PM in Packaging & Deployment

avatar image

TheMainStark
48 6 9 17

avatar image TheMainStark Sep 05 '18 at 07:31 PM

Forced stall at check disk stage:

alt text

When passed:

alt text

mobilepatch1.png (83.0 kB)
mobilepatch2.png (64.4 kB)
avatar image TheMainStark Sep 06 '18 at 04:59 AM

After the initial compile of the engine + project I deleted the MobilePatchUtility intermediate and binaries. Recompiled again and it appears to be working so far, I will update shortly.

avatar image TheMainStark Sep 08 '18 at 09:07 PM

I had the patch randomly work once, and it has not worked since. Trying to retrace my steps and figure out what it was. At the moment I posted this it just seemed like all I did was re compile the plugin but that has not worked since.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question