x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Stationary lights with source length flicker

Hello there,

As you can see **here**, depending on the angle the camera is in, the source length of the stationary lights seems to get set to 0 and back to the length it should be. They all change together, at the same time, for the entire level.

I have this problem since 4.17 and never found a solution to this.

Thanks in advance!

Product Version: UE 4.19
Tags:
more ▼

asked Sep 06 '18 at 11:36 AM in Rendering

avatar image

Philty Dragonbreath
19 4 6 13

avatar image daalta Sep 06 '18 at 11:44 AM

I've also had issues with long stationary lights - they caused very obvious white dots to appear at the seams between static meshes.

Never seen your issue though... Have you tried replicating this issue in an empty project?

avatar image Philty Dragonbreath Sep 06 '18 at 12:24 PM

Trying to replicate it as we speak, but I cannot seem to. I must say my current project is quite large...

This entry would seem to be the same kind of issue: https://answers.unrealengine.com/questions/412005/point-light-source-length-doesnt-work-with-tiledde.html?sort=oldest

Unresolved since Feb 2016...

avatar image Philty Dragonbreath Sep 06 '18 at 12:31 PM

Ok, I have been able to replicate it in an empty project!

If you have >80 point lights on stationary in your screen, it switches to 0 source length.

avatar image Philty Dragonbreath Sep 06 '18 at 01:01 PM

Manually setting the TiledDeferredShading minimum count to a higher amount fixes the problem, at least while you are in the editor. Default value is 80.

To set it higher, you can enter a console command, for example:

r.TiledDeferredShading.MinimumCount 200

I haven't found a way to set it in an .ini file or something, so it retains that value after you build the project...

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Adding this console command to the Event BeginPlay in your level blueprint does the trick. Not really a solution, more of a hack.

Increase/decrease the minimumcount to your liking. (Default = 80)

alt text

capt2.png (46.2 kB)
more ▼

answered Sep 06 '18 at 01:39 PM

avatar image

Philty Dragonbreath
19 4 6 13

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question