x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot Play Level when Pressing Play

Hello, I have just come across a problem that had not occurred before. When I want to play my level either in the Selected Viewport and/or as a Standalone Game, I cannot move my Character. W,A,S,D or any of the Controller Controls I have made do not work. The Scene also seems to be idle when moving Objects around the Scene and when attempting to Play. The Clouds in the Sky do not Rotate, nor do any of the Trees or Bushes even though they have Wind simulated upon them. I have double checked my Game Mode and any other Classes related to it but there are no errors. I'm very confused because everything was working fine yesterday.

This only occurs with this one Level. My other level is playable in full.

Can someone please help me, it will be much appreciated.

Thank You

Product Version: UE 4.19
Tags:
more ▼

asked Sep 06 '18 at 01:24 PM in Using UE4

avatar image

HALCYON Palace
6 1 2 2

avatar image mightyenigma Sep 06 '18 at 01:36 PM

Are there any errors in the message or Output logs? Did you set a Game Mode override for that level that doesn't use your usual PlayerController class and default Pawn class etc?

avatar image HALCYON Palace Sep 06 '18 at 01:50 PM

Hello, thank you for replying, Yes I have set a Game Mode override for the Level with the correct PC and Pawn Class.

There aren't any Error Messages

avatar image mightyenigma Sep 06 '18 at 02:01 PM

Hmm I don't know. How much effort would it be to recreate the Level in a different level? If all the others work maybe that will solve the problem if we can't identify what's going wrong.

avatar image HALCYON Palace Sep 06 '18 at 02:07 PM

It is quite a complex Level. But I can try and move it to another Level.

avatar image mightyenigma Sep 06 '18 at 02:12 PM

In your level blueprint, you don't have any Loops that run on Tick, do you?

avatar image HALCYON Palace Sep 06 '18 at 02:17 PM

No I haven't. Also I tried moving Level to another, and the same issues occur. I'm so confused.

avatar image mightyenigma Sep 06 '18 at 02:19 PM

Hmm me too. I thought maybe you had something in the blueprints that would slow it down a lot to make it look frozen.

avatar image HALCYON Palace Sep 06 '18 at 02:22 PM

I've just tried moving the Level to an existing Level that works and the issues have passed over to that Level. It used to work but now by moving the Level into it, its no longer working.

avatar image mightyenigma Sep 06 '18 at 02:38 PM

Okay then there might be a Blueprint class or other asset that you only used in the problematic level and not in the others, which causes the problem. Which asset or blueprint does not exist on any other level except that problematic one? The World Outliner lists all assets that are placed in the level before play starts.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question