x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[BUG] Animation Dialog w. Inconsistent Behavior

Version: 1627304

Install Path: C:\\users\\Markus\\

Specs: Win7, 16GB, GTX580, UAC on

Description: When you compile in an animation blueprint (see image below), you get this dialog that asks if you want to compile, and a checkbox option to automatically compile in the future (attached). But the thing is, if you check this option, it does not automatically compile as one would expect -- just makes the dialog go away (and I'm confused about how to bring that dialog back in the future, too...). You still have to manually press the compile button -- which is quite an irritation -- at least for animation blueprinting.

alt text

Repro Steps: Reproducing this is pretty simple. Start a new project. Open the content browser, right click, and create a new VIM blueprint. Import a skeletal mesh, and an animation for that mesh. Then open the new VIM blueprint, and then add a new animation from the right click menu. When you press the compile button on the top menu, it will give you this prompt. Check the box to make it go away in the future, and then start messing around with the animation blueprint -- add a blend node, add another animation sequence, or something in between to cause the compile button to mark the blueprint as dirty.

Results: Whatever you do in the above steps, you'll notice that all this does is mark the compile button as dirty instead of auto-saving the blueprint as one would expect.

Expected: Automatic saving, just like AnimTrees from UE3. If this is an issue with saving, can't you swap bytecode for the parts of the blueprint that have been changed or something? There must be some solution you can integrate for real-time compilation without having to bombard me as a user with constant point and click...

Product Version: Not Selected
Tags:
prompt_issue.png (46.4 kB)
more ▼

asked Mar 11 '14 at 04:02 AM in Everything Else

avatar image

ue4-archive ♦♦ STAFF
50k 3670 1999 9124

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Markus,

Thank you for reporting this. I looked into it and you are correct there seems to be no way to bring that dialog back, I have submitted a request for that to be brought in. Now as for the nature of that dialog, it just implies to always compile the blueprint when compiling and not to show that message. I've submitted a request to see if they can't word that a bit more clearly. As for the auto save; as of right now the only way to automatically save content is to turn on content auto save in the preferences, which only saves all unsaved content at certain time intervals. I have put in a request for this and the auto-compile request.

Best Regards,

Ryan

more ▼

answered Mar 11 '14 at 04:02 AM

avatar image

ue4-archive ♦♦ STAFF
50k 3670 1999 9124

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question