x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Why does the spline component reset after being created in blutility and moved in editor?

Hi there,

I wrote a blutility method which instantiates a blueprint class Something containing a spline component for every selected object with a spline component attached. So it's basically a converter which converts splines into other spline objects. Something doesn't have any construction script code and the event graph is also empty. It's only made of a spline component at the root.

Something class

Here's the conversion code. You can also download it to test it yourselves. Should work by just copy-and-pasting the text into a blutility function. Blutility Code

It seemed to work well. When I convert a spline and select the new one, it matches its original. Before move

If I move it however, the new spline resets to the default 2 node spline. After move

I have absolutely no clue why this is happening. First I was guessing because of the UpdateSpline option of the AddPoint method. But changing that didn't make a difference. Another guess would be the actor lifecycle but I have no idea what can go wrong there.

Thanks in advance,

Cheers

Product Version: UE 4.19
Tags:
something.png (37.7 kB)
before.png (69.0 kB)
after.png (69.4 kB)
more ▼

asked Sep 09 '18 at 05:46 PM in Blueprint Scripting

avatar image

xadrin
8 1 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello xadrin,

have you tried ticking the "Override Construction Script", in the Spline tab of Spline Component of your Something class?

Cheers.

more ▼

answered Sep 11 '18 at 12:01 PM

avatar image

UE_FlavienP
31 2 3

avatar image xadrin Sep 12 '18 at 05:34 AM

Hi UE_FlavienP,

Yup, that was it. Thanks very much.

Cheers, Stefan

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question