x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

ComboBoxString doesn't work with WidgetInteraction Component in packaged game

Hello,

I'm trying to package my game for a release tomorrow but my ComboBoxString in the main ui doesn't receive any actions performed by my ViveController which has a WidgetInteraction Component attached. All other UI elements work fine, the ComboBoxString, however, doesn't show its drop down menu when I press it. When I try it in the editor, it works just fine.

Is there something wrong with my setup or is it a bug? If the latter, is there a quick work-around as tomorrow is the release?

Thank you

Product Version: UE 4.20
Tags:
more ▼

asked Sep 11 '18 at 06:55 AM in Packaging & Deployment

avatar image

E1andri1
96 6 10 17

avatar image jeffym85 Oct 05 '18 at 03:30 PM

Did you figure out a workaround for this? We've encountered it as well.

avatar image E1andri1 Oct 05 '18 at 04:24 PM

well, I replaced the box with a set of buttons... no real workaround...but project due date was on 14th of September...

avatar image MykonCodes Oct 06 '18 at 12:02 AM

Hey there! I'm from the team of the guy above :P Just solved it, it's an engine bug and I have filed a report. If you are interested, the issue is deep down in engine code, for now you can solve it by adding

 bIsWindow = true;

to the "Construct()" function of SVirtualWindow

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

As mentioned in the comment, I have filed a bug report already. We had encountered the same problem.

Issue was that the widget-path tracing required an SWindow to be on the top of the hierachy, but WidgetComponents use only SVirtualWindow's which do not have that bIsWindow flag set to "true".

more ▼

answered Oct 06 '18 at 12:04 AM

avatar image

MykonCodes
96 8 15 25

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question