x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Goto defintion" option for BP nodes does nothing

So I was told that you can search for C++ function equivalents of Blueprint nodes if you right-click a blueprint node and choose "Goto Definition" (only works for C++ projects).

So I made a fresh new C++ project to test this out. Made a dummy blueprint and added a node to test but when I click "Goto Definition" nothing happens.

alt text

A little pop up window pops up in the bottom right corner saying "Reading C++ Symbols" and after that nothing happens.

alt text

I opened up my VS 2017 window to see if some .h or .cpp file opened up but nope... nothing.

Am I using this feature wrong or is this a bug? Help!

Product Version: UE 4.20
Tags:
capture.png (63.9 kB)
capture2.png (4.8 kB)
more ▼

asked Sep 12 '18 at 04:40 PM in C++ Programming

avatar image

Schytheron
56 3 6

avatar image Molo48 Oct 25 '18 at 06:54 PM

Same thing is happening to me

avatar image Kingtem Jan 24 '19 at 06:14 AM

Too shame this problem happened since 4.17 and still not be solved, even in 4.21.2. Before 4.17 everything's okay, you can easily "goto definition" in launcher-installed version. Do Epic has any solutions for this in the future?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Schytheron (and Molo48),

This is because you are using a launcher-installed version of the engine. The source-baked paths for those versions will not correspond to where you have the engine installed (unless that happens to be D:/++Build/UE4/Sync). However, it will work for any blueprint-exposed functions you create.

It is kind of a tedious workaround, but there is a way for you to view the source for a built-in Blueprint function. Using "Predict Projectile Path by TraceChannel" as an example, if you hover over the node in the editor you will see at the bottom of the tooltip what the target is. For that node, the target is "Gameplay Statics." If you then open GameplayStatics.h (located in %EngineInstallDir%/Engine/Source/Runtime/Engine/Classes/Kismet), you can see that the function Blueprint_PredictProjectilePath_ByTraceChannel has the display name of the node we're looking for. You can then open GameplayStatics.cpp (located in %EngineInstallDir%/Engine/Source/Runtime/Engine/Private) to find that function and view its source.

more ▼

answered Oct 26 '18 at 02:56 PM

DarkwindRichard (suspended)
(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question