x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE 4.20.2 Handheld AR template compiling but not running on any IOS device

I seem to be able to compile a Handheld AR Template App using my MAC, and it Packages too. However, the application will close right after opening. If I try to Launch, it will return Error=0 right up to the point of deployment but the app will never open. I checked my iPad Pro's Crash Logs using xCode10 and this is what it says: link text

So basically the App is crashing. I tried both iPad Pro and iPhone . Also, ran other UE4 templates and everything works as expected so the problem is only Handheld AR Template in IOS. I had also tried compiling on Windows for Android and Handheld AR template worked like a charm. Is there any solution to this problem in IOS?

Product Version: UE 4.20
Tags:
more ▼

asked Sep 17 '18 at 03:18 PM in Packaging & Deployment

avatar image

Pirata Pirate
1 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Found the issue. According to https://docs.unrealengine.com/en-us/Platforms/AR/HandheldAR/ARQuickStart HandheldAR template is supposed to configure and enable the Apple ARKit Plugin for you, but it doesn't. So it was just a matter of clicking "Enable" and restarting the Engine.

I just found it a little weird that it gave no compilation, packaging or launch error.

more ▼

answered Sep 17 '18 at 07:53 PM

avatar image

Pirata Pirate
1 1 2 4

avatar image HullzAngel Oct 17 '18 at 04:59 PM

Exactly that. It's insane that they released it as a template and made it officially part of the engine but forgot to have the plugin enabled by default when that project is created! OOPS!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question