x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to Release : System.NullReferenceException

Hi everyone,

I have a huge issue and I have no idea where it is coming from. I have to deploy really soon for a project, I hope someone will be able to help me !

I can't release my project any more lately, and don't really know why. I've searched but nothing helped.

Here is my output in project launcher :

 Running AutomationTool...
 [...]
 ********** BUILD COMMAND STARTED **********
 Running: C:\Program Files\Epic Games\UE_4.20\Engine\Binaries\DotNET\UnrealBuildTool.exe ProjectName Win64 Shipping -Project=D:\UE4\ProjectName\ProjectName.uproject  D:\UE4\ProjectName\ProjectName.uproject -NoUBTMakefiles  -remoteini="D:\UE4\ProjectName" -skipdeploy -noxge -generatemanifest -NoHotReload -log="%AppData Folder%\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_4.20\UBT-ProjectName-Win64-Shipping.txt"
   Using Visual Studio 2017 14.15.26726 toolchain (C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.15.26726) and Windows 10.0.17134.0 SDK (C:\Program Files (x86)\Windows Kits\10).
   Houdini Engine : Looking for Houdini Engine 16.5.571 in C:/Program Files/Side Effects Software/Houdini Engine 16.5.571
   Houdini Engine : Looking for Houdini 16.5.571 in D:\Program Files\Houdini
   Houdini Engine : Found Houdini in D:/Program Files/Houdini
   C:\Program Files\Epic Games\UE_4.20\Engine\Plugins\Runtime\HoudiniEngine\Source\HoudiniEngineRuntime\HoudiniEngineRuntime.Build.cs: warning: Referenced directory 'C:\Program Files\Epic Games\UE_4.20\Engine\Source\Plugins\Runtime\HoudiniEngine\Source\HoudiniEngineRuntime\Public\HAPI' does not exist.
   C:\Program Files\Epic Games\UE_4.20\Engine\Plugins\Runtime\HoudiniEngine\Source\HoudiniEngineRuntime\HoudiniEngineRuntime.Build.cs: warning: Referenced directory 'C:\Program Files\Epic Games\UE_4.20\Engine\Source\Plugins\Runtime\HoudiniEngine\Source\HoudiniEngineRuntime\Public' does not exist.
   D:\UE4\ProjectName\Plugins\WebSocket\Source\WebSocket\WebSocket.Build.cs: warning: Referenced directory 'C:\Program Files\Epic Games\UE_4.20\Engine\Source\WebSocket\Public' does not exist.
   ERROR: System.NullReferenceException: La référence d'objet n'est pas définie à une instance d'un objet.
             à UnrealBuildTool.UEBuildBinary.<>c.<SetupBinaryLinkEnvironment>b__35_0(FileItem Item) dans D:\Build\++UE4\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Configuration\UEBuildBinary.cs:ligne 623
             à System.Linq.Enumerable.WhereSelectListIterator`2.MoveNext()
             à System.Linq.Enumerable.Any[TSource](IEnumerable`1 source, Func`2 predicate)
             à UnrealBuildTool.UEBuildBinary.SetupBinaryLinkEnvironment(ReadOnlyTargetRules Target, UEToolChain ToolChain, LinkEnvironment LinkEnvironment, CppCompileEnvironment CompileEnvironment, List`1 SharedPCHs, ISourceFileWorkingSet WorkingSet, ActionGraph ActionGraph) dans D:\Build\++UE4\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Configuration\UEBuildBinary.cs:ligne 623
             à UnrealBuildTool.UEBuildBinary.Build(ReadOnlyTargetRules Target, UEToolChain ToolChain, CppCompileEnvironment CompileEnvironment, LinkEnvironment LinkEnvironment, List`1 SharedPCHs, ISourceFileWorkingSet WorkingSet, ActionGraph ActionGraph) dans D:\Build\++UE4\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Configuration\UEBuildBinary.cs:ligne 196
             à UnrealBuildTool.UEBuildTarget.Build(BuildConfiguration BuildConfiguration, CPPHeaders Headers, List`1 OutputItems, List`1 UObjectModules, ISourceFileWorkingSet WorkingSet, ActionGraph ActionGraph, EHotReload HotReload, Boolean bIsAssemblingBuild) dans D:\Build\++UE4\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Configuration\UEBuildTarget.cs:ligne 2357
             à UnrealBuildTool.UnrealBuildTool.RunUBT(BuildConfiguration BuildConfiguration, String[] Arguments, FileReference ProjectFile, Boolean bCatchExceptions) dans D:\Build\++UE4\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\UnrealBuildTool.cs:ligne 1480
          (see %AppData Folder%\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_4.20\UBT-ProjectName-Win64-Shipping.txt for full exception trace)
 Took 3,431997s to run UnrealBuildTool.exe, ExitCode=5
 ERROR: UnrealBuildTool failed. See log for more details. (%AppData Folder%\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_4.20\UBT-ProjectName-Win64-Shipping.txt)
        (see %AppData Folder%\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_4.20\Log.txt for full exception trace)
 AutomationTool exiting with ExitCode=5 (5)
 BUILD FAILED

Here is Log.Txt in the automation tool folder : Log.txt on textshare

I tried deleting .vs/Binaries/Intermediate/Folder/.sln and regenerating, but it fixed nothing.

I think it might be coming from the HoudiniEngine Plugin, but it would really help if I could use it.

I can generate my project in Visual Studio Only in Development Editor and DebugGame Editor, but not Development, DebugGame and Shipping, so I have no way to release my project.

Any ideas ? I'm gonna continue try fixing it, but any help would be appreciated !

If you need more info, don't hesitate to ask.

Thanks to anyone who took the time to read my issue.

EDIT : Ok I should have tried that earlier but when I remove the Houdini Engine plugin everything works fine... not really the fix I'm hoping for though...

Product Version: UE 4.20
Tags:
more ▼

asked Sep 18 '18 at 09:27 AM in Packaging & Deployment

avatar image

The Yojimbo
58 2 5 9

avatar image undercover Nov 06 '18 at 09:54 AM

We also have this problem. Thanks for sharing! +1

avatar image Van Aarde Dec 09 '18 at 04:42 PM

Thanks for this! We had the exact same problem.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Copy the HoudiniEngine folder from C:\Program Files\Side Effects Software\Houdini XX.Y.ZZZ\engine\unreal\4.XX to X:\Path\To\YourUE4Project\Plugins\Engine\Runtime\

more ▼

answered Feb 22 '19 at 02:29 PM

avatar image

sdouce_playwing
11 1 1

avatar image LittleShrimpABC Mar 11 '19 at 02:36 AM

I have the same problem, it worked, thx ! :)

avatar image drichardson Mar 19 '19 at 03:39 AM

What on earth? This worked for me too. Is this documented somewhere on Side FX's site?

avatar image JasperDre Mar 21 '19 at 08:54 PM

Worked for me as well. A bit of a strange fix since the Houdini plugin has existed for quite some time, but the UBT still doesn't detect it from the UE folder.

avatar image drichardson Mar 21 '19 at 10:59 PM

FYI I've reported this to Side FX and they are looking into it.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question