x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Network Vehicle Bug when switching between Vehicle client's level reset to default map in 4.2.1

Hi, here how you can reproduce the bug

  1. Create New Blueprint Vehicle Project

  2. Drop 1 Sedan blueprint in level

  3. Make a new PlayerController Blueprint and set it to default player controller in World Setting

  4. Set Target is the Sedan in level and Default is the Default Pawn.

  5. alt text

  6. Make a server event to tell server to switch between Default and Target when pressed F

  7. alt text

  8. Set PIE to 1 client and Dedicated Server and Play.

  9. In beginning move little bit, then press F to switch control to a other Sedan, this work as supposed.

  10. Press F again to switch back to Default Pawn, you will see client level set will be reset to Default Map.

  11. After that one time it work like it's supposed to be.

  12. NOTE: it only happen when i set all 4 wheels of VehicleMovement component.

Product Version: Not Selected
Tags:
more ▼

asked Aug 13 '14 at 10:48 AM in Bug Reports

avatar image

Duncan Dam
3.1k 121 50 164

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Duncan,

I set up a project with settings as you've described, and I am seeing a similar issue. When I hit Play, then move the default sedan forward, then hit F, it switches to the other sedan for 1 second and then switches back to the default pawn in its starting position.

I'm checking in with our developers to see if there's something we've missed, and if not we'll make sure to open a bug report for the issue. Thanks for the report!

more ▼

answered Aug 13 '14 at 05:53 PM

avatar image Duncan Dam Aug 14 '14 at 01:32 AM

Thank you, hope this gonna fix soon or there some work around ^^ Kind of need my vehicle working.

avatar image Ben Halliday STAFF Aug 14 '14 at 03:49 PM

I'm still waiting to hear back from the developers on this. If you don't mind, I'd like to leave this post as unresolved so I can keep track of it better until then. Thanks!

avatar image [Epic] John Pollard STAFF Aug 14 '14 at 09:31 PM

Hi Duncan,

It appears the problem is that when you switch possession to the new vehicle, the old vehicle wheels continue to send RPC's to the server. This is because the wheels incorrectly (this is the bug) think they are still possessed by the original player controller.

Because of the log spam generated, the server disconnects the client, and you are now a listen server, and no longer connected to a server (this is why it now works the second time).

I'm looking into a fix now, and hopefully this will be fixed soon.

avatar image [Epic] John Pollard STAFF Aug 14 '14 at 10:00 PM

Quick follow up, a fix for this has gone in, and should hopefully be in the next release.

avatar image Duncan Dam Aug 18 '14 at 01:25 AM

Awesome, thank a lot.

To be clear, this fix is this already in 4.4 or it'll be on 4.5 ?

avatar image Ben Halliday STAFF Aug 18 '14 at 03:21 PM

It'll be 4.5, as we had already locked down on 4.4 when this fix went in.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question