Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Swarm Agent failed to kick off, tried everything. Why?!?!?!

Tried everything, from clearing swarm cache, to deleting folders, ini files, reinstalling the engine, and delete map assets, with no results. Happens on 4.20.3, 4.19, and It is driving me crazy. It only happens in 1 map, and if I delete everything, fine, light builds, if I leave 1 single actor, it says to recompile lightmass because swarm agent failed to kick off, but I didn't build from source, I'm using the launcher. Also tried running swarm agent as admin, nothing. It was all fine until unreal crashed after building the light for these maps, and they are final, production-ready maps, full of meshes and triggered events... please don't tell me I have to redo all of it, please, or I think I might as well give up already, getting sick and tired of Unreal's crap. It is a nice toy to play around with, but I am starting to understand why so many studios go for unity... and I don't want to change, but I rather do it then kill my project because of the engine's bugs and constant crashes...

Product Version: UE 4.20
more ▼

asked Sep 19 '18 at 05:47 PM in Using UE4

avatar image


avatar image neighborlee May 04 '19 at 04:41 PM

Did you figure this out, my project also is having problems, where building light is odd as the swarm agent doesn't start viz; I have medium quality light settings, 4tile world comp system, yet lighting builds in 2minutes or so.

Any idea and did you get you're issue resolved ?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question