x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Bug] GameMode cannot be changed once set to custom BP GameMode

Hey guys,

So I have my original gamemode C++ class created automatically on project creation; FlightPrototypeGameMode. In it, all I've added is an override of BeginPlay, which does still call Super::BeginPlay, so all good. I have a blueprint gamemode called BP_GameMode which inherits from this class.

In the editor, my gamemode is set to BP_GameMode, as per the following;

alt text

Which results in the following entry in DefaultEngine.ini;

GlobalDefaultGameMode=/Script/Engine.GameMode GlobalDefaultGameMode=/Game/Blueprints/Core/BP_Gamemode.BP_Gamemode_C GlobalDefaultServerGameMode=/Game/Blueprints/Core/BP_Gamemode.BP_Gamemode_C

When I change this gamemode listing to the following (which inherits from my new C++ gamemode, called TeamEliminationGameMode, which overrides BeginPlay and ChoosePlayerStart, but has Super:: calls in both, so no alterations to overall behaviour);

alt text

My DefaultEngine.ini's entry changes to this;

GlobalDefaultGameMode=/Script/Engine.GameMode GlobalDefaultGameMode=/Game/Blueprints/Core/Gamemodes/BP_TeamElimination.BP_TeamElimination_C GlobalDefaultServerGameMode=/Game/Blueprints/Core/Gamemodes/BP_TeamElimination.BP_TeamElimination_C

The problem is that it still loads up BP_GameMode when I hit 'play'. I've tested this by setting a different default pawn in BP_TeamElimination and checking if that one is used (it isn't), and by setting breakpoints on this BP's BeginPlay node, which is never executed (however BP_GameMode's is, even though it's no longer selected as the default GameMode).

Any ideas?

Thanks.

EDIT: Don't know what happened to my image links. They're still valid, and the images are attached to this post.

Product Version: Not Selected
Tags:
more ▼

asked Aug 13 '14 at 01:07 PM in Bug Reports

avatar image

HateDread
453 41 47 72

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Turns out I still had 'GameMode Override' in World Settings of my test level set to 'BP_GameMode', rather than 'None'. Solved.

more ▼

answered Aug 17 '14 at 09:15 AM

avatar image

HateDread
453 41 47 72

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question