x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error: Runnable thread AudioThread crashed.

I'm not sure if this is something I did or the latest hot fix 4.20.3 that caused this to happen. Inside editor everything is fine, no crash when doing the same steps. Once I package m game though I go to my main menu, click play (which opens a map which is the actual game) and I get this crash.

The log reports this.

https://hastebin.com/zehorequcu.md

There are lots of "Waited 2475.292236ms for audio thread" posting in the log before the crash happens. I can't debug since it happens only in the game and I can't few the methods in the stack trace unless their is a trick to do so?

The project has one C++ class so I tried deleting intermediate and saved folder before rebuilding to no avail.

Product Version: UE 4.20
Tags:
more ▼

asked Sep 24 '18 at 02:32 PM in Bug Reports

avatar image

Nonlin
109 7 17 18

avatar image Jeff A ♦♦ STAFF Sep 24 '18 at 07:27 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

avatar image Nonlin Sep 25 '18 at 03:21 AM

What if I'm not sure if it is an engine bug or otherwise? I'm not sure what the steps to reproduce are so I'm currently refraining from submitting anything there. Thanks for the heads up though.

Perhaps this needs to be moved?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I've found the problem but haven't made sense of it yet.

The problem BP node was Push Sound Mix Modifier but the pushing alone wasn't the issue it was the file it was pushing. I instead made a new "Sound Mix" file and used that instead and the crash went away.

The original sound mix file was made in 4.20.2 and I can only guess moving from it to 4.20.3 caused the issue or something else went wrong?

If someone can advise how I can drop down to 4.20.2 to reproduce great if not I'm not sure what else to say other than if someone else runs into this, see if removing "Push Sound Mix Modifier" helps and if it does trying making a new Sound Mix file and use that instead.

more ▼

answered Sep 25 '18 at 04:29 AM

avatar image

Nonlin
109 7 17 18

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question