Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Current Material Compilation Errors SM5

Hi All,

I recently installed the UE4 but it doesn't work properly.

In Material window it gives me various errors just after opening the material/ even when I use the starter materials they vanish as soon as I open the material window and the sm5 errors get displayed:

i.e. [SM5] /tmp/5078_2741049389.metal(0): Failed to load output file: /tmp/ShaderIn

There are like 15 of them Please see attached screenshot

I tried hooking up the base colour, normals, and AO maps but they don't get displayed on material alt text I am a Mac user I tried uninstalling and downloading epic games again but it doesn't help little help please :)

Product Version: UE 4.18
more ▼

asked Sep 25 '18 at 07:35 PM in Bug Reports

avatar image

1 1 2

avatar image Jeff A ♦♦ STAFF Sep 26 '18 at 05:39 PM


We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.



(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Apparently I had an old version of UE and I have been just deleting the epic games loader not reinstalling my unreal here's what helped :


Best, Pit

more ▼

answered Sep 26 '18 at 06:24 PM

avatar image

1 1 2

avatar image Nantuk Jan 15 '19 at 09:23 PM

sorry, I don't understand. I'm having this issue as well. What would having another versions of UE installed have to do with seeing these errors? Did uninstalling/reinstalling solve the issue for you?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question