x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to make RenderTarget not show certain mesh

Hello,
I want to filter a mesh in my RenderTarget2D, in this case the mesh of the current player I'm controlling.
Here is the problem : i made the player mesh invisible for the player controlling it by this checkbox "owner no see".
it works fine but when i use the RenderTarget (the RenderTarget is a weapon scope here and game is a TPS) i can see my own player mesh through it.

  • Is there anyway i could make it not show my player mesh in RenderTarget?

Product Version: UE Github Master branch
Tags:
more ▼

asked Sep 26 '18 at 10:17 AM in Blueprint Scripting

avatar image

THIECK
17 1 2 7

avatar image HarryHighDef Sep 26 '18 at 10:44 AM

How are you rendering to the target?

avatar image THIECK Sep 26 '18 at 01:46 PM

I'm using SceneCaptureComponent2D. @HarryHighDef

avatar image mightyenigma Sep 26 '18 at 09:47 PM

On the bright side you just came up with a way to make a feature where the player can only see a cloaked monster through special viewing equipment

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question